diff options
author | Ting Liu <b28495@freescale.com> | 2013-03-13 07:49:42 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-03-25 12:56:06 +0100 |
commit | 7c27c81a1bfc7b11ae7d7747b5c669776cbc328f (patch) | |
tree | 541144f8daaa246bc0dc73cb0e96c619b3402d90 /meta-oe/recipes-support/lio-utils | |
parent | 6cbd81ed18465affba841311ec1cdf3eb6800dba (diff) | |
download | meta-openembedded-7c27c81a1bfc7b11ae7d7747b5c669776cbc328f.tar.gz |
lio-utils: initial add 4.1
lio-utils (lio-utils.git) provide a simple low-level configuration tool
set for the Target+iSCSI (LIO).
lio-utils use the configFS kernel API that is available with LIO, which
provides a clean interface for controlling the kernel level Target
engine and its fabric module subsystems.
Signed-off-by: Ting Liu <b28495@freescale.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lio-utils')
-rw-r--r-- | meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb | 59 |
1 files changed, 59 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb b/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb new file mode 100644 index 000000000..bbedb784a --- /dev/null +++ b/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb | |||
@@ -0,0 +1,59 @@ | |||
1 | SUMMARY = "lio-utils" | ||
2 | DESCRIPTION = "a simple low-level configuration tool set for the Target+iSCSI (LIO)" | ||
3 | HOMEPAGE = "http://linux-iscsi.org/index.php/Lio-utils" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=c3ea231a32635cbb5debedf3e88aa3df" | ||
6 | |||
7 | PV = "4.1+git${SRCPV}" | ||
8 | |||
9 | SRC_URI = "git://risingtidesystems.com/lio-utils.git" | ||
10 | SRCREV = "28bd928655bdc7bd3cf380f0196630690c51e05f" | ||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | inherit distutils | ||
14 | |||
15 | EXTRA_OEMAKE += "DESTDIR=${D}" | ||
16 | |||
17 | do_compile() { | ||
18 | cd ${S}/tcm-py | ||
19 | distutils_do_compile | ||
20 | |||
21 | cd ${S}/lio-py | ||
22 | distutils_do_compile | ||
23 | |||
24 | if test -d ${S}/tools; then | ||
25 | oe_runmake -C ${S}/tools | ||
26 | fi | ||
27 | } | ||
28 | |||
29 | do_install() { | ||
30 | cd ${S}/tcm-py | ||
31 | distutils_do_install | ||
32 | |||
33 | cd ${S}/lio-py | ||
34 | distutils_do_install | ||
35 | |||
36 | SITE_PACKAGES=${D}/${PYTHON_SITEPACKAGES_DIR} | ||
37 | install -d ${D}/${sbindir} | ||
38 | for var in tcm_node tcm_dump tcm_loop tcm_fabric lio_dump lio_node; do | ||
39 | if [ ! -h ${D}/${sbindir}/${var} ];then | ||
40 | chmod a+x ${SITE_PACKAGES}/${var}.py | ||
41 | ln -s ${PYTHON_SITEPACKAGES_DIR}/${var}.py ${D}/${sbindir}/${var} | ||
42 | fi | ||
43 | done | ||
44 | |||
45 | if test -d ${S}/tools; then | ||
46 | oe_runmake -C ${S}/tools install | ||
47 | fi | ||
48 | |||
49 | install -d ${D}/etc/target/ | ||
50 | install -d ${D}/etc/init.d/ | ||
51 | install -m 755 ${S}/scripts/rc.target ${D}/etc/init.d/ | ||
52 | install -m 755 ${S}/conf/tcm_start.default ${D}/etc/target/tcm_start.sh | ||
53 | install -m 755 ${S}/conf/lio_start.default ${D}/etc/target/lio_start.sh | ||
54 | } | ||
55 | |||
56 | RDEPENDS_${PN} += "python-stringold python-subprocess python-shell \ | ||
57 | python-datetime python-textutils python-crypt python-netclient python-email" | ||
58 | |||
59 | FILES_${PN} += "${sbindir}/* /etc/init.d/* /etc/target/*" | ||