summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/links
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/links
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/links')
-rw-r--r--meta-oe/recipes-support/links/files/ac-prog-cxx.patch11
-rw-r--r--meta-oe/recipes-support/links/files/links2.desktop14
-rw-r--r--meta-oe/recipes-support/links/links-x11_2.7.bb27
-rw-r--r--meta-oe/recipes-support/links/links.inc17
-rw-r--r--meta-oe/recipes-support/links/links_2.7.bb13
5 files changed, 82 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/links/files/ac-prog-cxx.patch b/meta-oe/recipes-support/links/files/ac-prog-cxx.patch
new file mode 100644
index 000000000..41c382685
--- /dev/null
+++ b/meta-oe/recipes-support/links/files/ac-prog-cxx.patch
@@ -0,0 +1,11 @@
1--- links-2.1pre20/configure.in.orig 2005-12-21 15:23:49.000000000 +0000
2+++ links-2.1pre20/configure.in 2005-12-21 15:23:59.000000000 +0000
3@@ -18,7 +18,7 @@
4 dnl Checks for programs.
5 AC_PROG_CC
6
7-#AC_PROG_CXX
8+AC_PROG_CXX
9 #AC_PROG_AWK
10 #AM_PROG_LEX
11 #AC_PROG_YACC
diff --git a/meta-oe/recipes-support/links/files/links2.desktop b/meta-oe/recipes-support/links/files/links2.desktop
new file mode 100644
index 000000000..a05bce1b2
--- /dev/null
+++ b/meta-oe/recipes-support/links/files/links2.desktop
@@ -0,0 +1,14 @@
1[Desktop Entry]
2Encoding=UTF-8
3Name=Links
4Comment=Links is a browser very similar to lynx
5Comment[es]=El links es un browser para modo texto, similar a lynx
6Comment[pl]=Links jest przeglądarką podobną do lynksa
7Comment[pt]=O links é um browser para modo texto, similar ao lynx
8Comment[pt_BR]=O links é um browser para modo texto, similar ao lynx
9Exec=links -g
10Terminal=true
11Icon=links2
12Type=Application
13Categories=Application;ConsoleOnly;Network;WebBrowser;
14# vi: encoding=utf-8
diff --git a/meta-oe/recipes-support/links/links-x11_2.7.bb b/meta-oe/recipes-support/links/links-x11_2.7.bb
new file mode 100644
index 000000000..87666534e
--- /dev/null
+++ b/meta-oe/recipes-support/links/links-x11_2.7.bb
@@ -0,0 +1,27 @@
1require links.inc
2
3DEPENDS += "virtual/libx11"
4RCONFLICTS_${PN} = "links"
5
6SRC_URI += " file://links2.desktop \
7 http://www.xora.org.uk/oe/links2.png;name=icon"
8
9S = "${WORKDIR}/links-${PV}"
10
11EXTRA_OECONF = "--enable-graphics \
12 --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
13 --without-libtiff --without-svgalib --without-fb \
14 --without-directfb --without-pmshell --without-atheos \
15 --with-x --without-gpm"
16
17do_install_append() {
18 install -d ${D}/${datadir}/applications
19 install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications
20 install -d ${D}/${datadir}/pixmaps
21 install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps
22}
23
24SRC_URI[md5sum] = "d06aa6e14b2172d73188871a5357185a"
25SRC_URI[sha256sum] = "0c182b1cbcdfd5cdcd2f75a6032d1a4b660d07c1225c1e07757cec81d3302130"
26SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33"
27SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47"
diff --git a/meta-oe/recipes-support/links/links.inc b/meta-oe/recipes-support/links/links.inc
new file mode 100644
index 000000000..e07240820
--- /dev/null
+++ b/meta-oe/recipes-support/links/links.inc
@@ -0,0 +1,17 @@
1DESCRIPTION = "Links is graphics and text mode WWW \
2browser, similar to Lynx."
3HOMEPAGE = "http://links.twibright.com/"
4SECTION = "console/network"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=65e735be2e05d5943803344148f57603"
7DEPENDS = "jpeg libpng flex openssl zlib"
8
9SRC_URI = "http://links.twibright.com/download/links-${PV}.tar.bz2 \
10 file://ac-prog-cxx.patch \
11"
12
13PACKAGECONFIG ??= ""
14PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
15PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
16
17inherit autotools pkgconfig
diff --git a/meta-oe/recipes-support/links/links_2.7.bb b/meta-oe/recipes-support/links/links_2.7.bb
new file mode 100644
index 000000000..e80dd7bca
--- /dev/null
+++ b/meta-oe/recipes-support/links/links_2.7.bb
@@ -0,0 +1,13 @@
1require links.inc
2
3DEPENDS += "gpm"
4RCONFLICTS_${PN} = "links-x11"
5
6EXTRA_OECONF = "--enable-graphics \
7 --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
8 --without-libtiff --without-svgalib --with-fb \
9 --without-directfb --without-pmshell --without-atheos \
10 --without-x"
11
12SRC_URI[md5sum] = "d06aa6e14b2172d73188871a5357185a"
13SRC_URI[sha256sum] = "0c182b1cbcdfd5cdcd2f75a6032d1a4b660d07c1225c1e07757cec81d3302130"