summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libutempter
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2014-12-04 10:13:40 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-10 13:33:29 +0100
commit199cabe788f80efe517e4c3cccca8e046621bfb7 (patch)
treee1a061c9c41f204afd4c12871bd7d89d72aa81a1 /meta-oe/recipes-support/libutempter
parentc785f164ccd47fb15a319c1f98ddde44cdbf400d (diff)
downloadmeta-openembedded-199cabe788f80efe517e4c3cccca8e046621bfb7.tar.gz
libutempter: Add new recipe
Libutempter provides interface for terminal emulators such as screen and xterm to record user sessions to utmp and wtmp files. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libutempter')
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb b/meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb
new file mode 100644
index 000000000..e1dccd651
--- /dev/null
+++ b/meta-oe/recipes-support/libutempter/libutempter_1.1.6.bb
@@ -0,0 +1,36 @@
1SUMMARY = "A privileged helper for utmp/wtmp updates"
2DESCRIPTION = "\
3This library provides interface for terminal emulators such as \
4screen and xterm to record user sessions to utmp and wtmp files."
5HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter"
6SECTION = "System Environment/Libraries"
7LICENSE = "GPLv2 GPLv2+ LGPLv2 MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
9
10SRC_URI = "ftp://ftp.altlinux.org/pub/people/ldv/utempter/${BP}.tar.bz2"
11SRC_URI[md5sum] = "b43827806923903aba2bc7cd3a2d45b7"
12SRC_URI[sha256sum] = "b898565f31ced7e5c1fa0a2eaa0f6ff0ed862b5fe375d26375b64bfbdfeac397"
13
14CFLAGS += "-DLIBEXECDIR=$(libexecdir)"
15
16do_compile() {
17 oe_runmake \
18 libdir=${libdir} \
19 libexecdir=${libexecdir} \
20}
21
22do_install() {
23 oe_runmake install \
24 DESTDIR=${D} \
25 libdir="${libdir}" \
26 libexecdir="${libexecdir}" \
27 includedir=${includedir} \
28 mandir=${mandir}
29
30 rm -f ${D}${libdir}/*.a
31}
32
33FILES_${PN} = "${libdir}/*.so.*"
34FILES_${PN} += "${libexecdir}/utempter/utempter"
35
36FILES_${PN}-dbg += "${libexecdir}/utempter/.debug/utempter"