summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libusbg
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/libusbg
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/libusbg')
-rw-r--r--meta-oe/recipes-support/libusbg/libusbg/0001-Fix-out-of-tree-builds.patch39
-rw-r--r--meta-oe/recipes-support/libusbg/libusbg_git.bb16
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libusbg/libusbg/0001-Fix-out-of-tree-builds.patch b/meta-oe/recipes-support/libusbg/libusbg/0001-Fix-out-of-tree-builds.patch
new file mode 100644
index 000000000..6be49fbca
--- /dev/null
+++ b/meta-oe/recipes-support/libusbg/libusbg/0001-Fix-out-of-tree-builds.patch
@@ -0,0 +1,39 @@
1From 6118c6ec1291a5c731aa8d4f0c1eb8cce43d47ad Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Mon, 4 Aug 2014 09:04:08 +0200
4Subject: [PATCH] Fix out-of-tree builds
5
6The include flag should point to the source directory, not the build
7directory.
8
9Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
10Upstream-status: Submitted [https://github.com/libusbg/libusbg/pull/9]
11---
12 examples/Makefile.am | 2 +-
13 src/Makefile.am | 2 +-
14 2 files changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/examples/Makefile.am b/examples/Makefile.am
17index f9f9407..ef4f81e 100644
18--- a/examples/Makefile.am
19+++ b/examples/Makefile.am
20@@ -1,5 +1,5 @@
21 bin_PROGRAMS = show-gadgets gadget-acm-ecm
22 gadget_acm_ecm_SOURCES = gadget-acm-ecm.c
23 show_gadgets_SOURCES = show-gadgets.c
24-AM_CPPFLAGS=-I../include/
25+AM_CPPFLAGS=-I$(top_srcdir)/include/
26 AM_LDFLAGS=-L../src/ -lusbg
27diff --git a/src/Makefile.am b/src/Makefile.am
28index d955a4c..2f71366 100644
29--- a/src/Makefile.am
30+++ b/src/Makefile.am
31@@ -1,4 +1,4 @@
32 lib_LTLIBRARIES = libusbg.la
33 libusbg_la_SOURCES = usbg.c
34 libusbg_la_LDFLAGS = -version-info 0:1:0
35-AM_CPPFLAGS=-I../include/
36+AM_CPPFLAGS=-I$(top_srcdir)/include/
37--
381.9.0
39
diff --git a/meta-oe/recipes-support/libusbg/libusbg_git.bb b/meta-oe/recipes-support/libusbg/libusbg_git.bb
new file mode 100644
index 000000000..97d60a6a8
--- /dev/null
+++ b/meta-oe/recipes-support/libusbg/libusbg_git.bb
@@ -0,0 +1,16 @@
1SUMMARY = "USB Gadget Configfs Library"
2
3LICENSE = "GPLv2 & LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c"
6
7inherit autotools
8
9PV = "0.1.0"
10SRCREV = "a826d136e0e8fa53815f1ba05893e6dd74208c15"
11SRC_URI = "git://github.com/libusbg/libusbg.git \
12 file://0001-Fix-out-of-tree-builds.patch \
13 "
14
15S = "${WORKDIR}/git"
16