summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-04-05 23:23:13 -0700
committerKhem Raj <raj.khem@gmail.com>2023-04-06 13:45:01 -0700
commit8b0fe7a1d1e485befed2f4abedcaf6c6c8822b0e (patch)
tree59f4612aff92f65cf52ffb2fdd5bb0e244b82bf5 /meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
parent3e4121b6e7192b2d98fdd533d5ca8270914f5589 (diff)
downloadmeta-openembedded-8b0fe7a1d1e485befed2f4abedcaf6c6c8822b0e.tar.gz
libtinyxml2: Add ptest support
- Switch to usong meson build system - Fix build with musl by defining _LARGEFILE64_SOURCE Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb')
-rw-r--r--meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb18
1 files changed, 13 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
index 7f205987f..7ef4d89ce 100644
--- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
+++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
@@ -4,14 +4,22 @@ SECTION = "libs"
4LICENSE = "Zlib" 4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd" 5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
6 6
7SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https"
8
9SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82" 7SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82"
8SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
9 file://run-ptest"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13inherit cmake 13inherit meson ptest
14 14
15BBCLASSEXTEND = "native" 15EXTRA_OEMESON += "${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true', '', d)}"
16
17CXXFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"
16 18
17EXTRA_OECMAKE += "-Dtinyxml2_SHARED_LIBS=YES" 19do_install_ptest() {
20 install -Dm 0755 ${B}/xmltest ${D}${PTEST_PATH}/xmltest
21 install -d ${D}${PTEST_PATH}/resources/out
22 install -Dm 0644 ${B}/resources/*.xml ${D}${PTEST_PATH}/resources/
23}
24
25BBCLASSEXTEND = "native"