summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libteam/libteam_1.31.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-12-02 15:59:47 +0800
committerKhem Raj <raj.khem@gmail.com>2021-12-02 07:52:17 -0800
commita12cd7869b4f6ff11e6b67dd3f243298941641e7 (patch)
tree8280d6681776b4335c552ccdea434b362620e068 /meta-oe/recipes-support/libteam/libteam_1.31.bb
parentd0f133d642fe88b9c0bf93cbee3c31c7a9cd17db (diff)
downloadmeta-openembedded-a12cd7869b4f6ff11e6b67dd3f243298941641e7.tar.gz
libteam: switch to python3
The original fix for team_basic_test.py only change the interpreter to python3, but still some error as below: # ./run-ptest File "/usr/lib64/libteam/ptest/./team_basic_test.py", line 35 print "Usage: team_basic_test.py [OPTION...]" ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ SyntaxError: Missing parentheses in call to 'print'. Did you mean print(...)? # ./run-ptest RUN #1 # "ip link add testteamx type team" # "teamnl testteamx getoption mode" # "ip link del testteamx" # "modprobe -r team_mode_loadbalance team_mode_roundrobin team_mode_activebackup team_mode_broadcast team" Traceback (most recent call last): File "/usr/lib64/libteam/ptest/./team_basic_test.py", line 206, in <module> main() File "/usr/lib64/libteam/ptest/./team_basic_test.py", line 203, in main btest.run() File "/usr/lib64/libteam/ptest/./team_basic_test.py", line 180, in run self._run_one_loop(i + 1) File "/usr/lib64/libteam/ptest/./team_basic_test.py", line 173, in _run_one_loop self._run_one_mode(mode_name) File "/usr/lib64/libteam/ptest/./team_basic_test.py", line 101, in _run_one_mode cmd_exec("teamnl %s getoption mode" % team_name, "*NOMODE*") File "/usr/lib64/libteam/ptest/./team_basic_test.py", line 80, in cmd_exec raise CmdExecUnexpectedOutputException(output, expected_output) __main__.CmdExecUnexpectedOutputException: Command execution output unexpected: "b'*NOMODE*'" != "*NOMODE*" So rework team_basic_test.py to fix the above issue. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libteam/libteam_1.31.bb')
-rw-r--r--meta-oe/recipes-support/libteam/libteam_1.31.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libteam/libteam_1.31.bb b/meta-oe/recipes-support/libteam/libteam_1.31.bb
index f1cad9321..a3bed722e 100644
--- a/meta-oe/recipes-support/libteam/libteam_1.31.bb
+++ b/meta-oe/recipes-support/libteam/libteam_1.31.bb
@@ -11,7 +11,7 @@ SRC_URI = "git://github.com/jpirko/libteam;branch=master;protocol=https \
11 file://0001-include-sys-select.h-for-fd_set-definition.patch \ 11 file://0001-include-sys-select.h-for-fd_set-definition.patch \
12 file://0002-teamd-Re-adjust-include-header-order.patch \ 12 file://0002-teamd-Re-adjust-include-header-order.patch \
13 file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ 13 file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \
14 file://0001-team_basic_test.py-use-python3-interpreter.patch \ 14 file://0001-team_basic_test.py-switch-to-python3.patch \
15 file://run-ptest \ 15 file://run-ptest \
16 " 16 "
17SRCREV = "3ee12c6d569977cf1cd30d0da77807a07aa77158" 17SRCREV = "3ee12c6d569977cf1cd30d0da77807a07aa77158"