diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-07 12:41:49 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 00:01:46 +0200 |
commit | 09566d518a56a413303d7d13d496254b467c635b (patch) | |
tree | 9e3686df31d6b4fa945e09a1bc4ab659323f6404 /meta-oe/recipes-support/libsdl-ttf | |
parent | 555b3d6e3dc2703297014f161789ea932f71fa54 (diff) | |
download | meta-openembedded-09566d518a56a413303d7d13d496254b467c635b.tar.gz |
libsdl-ttf: fix build without freetype-config
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libsdl-ttf')
-rw-r--r-- | meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/use.pkg-config.for.freetype2.patch | 57 | ||||
-rw-r--r-- | meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb | 1 |
2 files changed, 58 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/use.pkg-config.for.freetype2.patch b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/use.pkg-config.for.freetype2.patch new file mode 100644 index 000000000..8a11f6649 --- /dev/null +++ b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/use.pkg-config.for.freetype2.patch | |||
@@ -0,0 +1,57 @@ | |||
1 | freetype-config was removed from oe-core in | ||
2 | |||
3 | commit 5870bd272b0b077d0826fb900b251884c1c05061 | ||
4 | Author: Richard Purdie <richard.purdie@linuxfoundation.org> | ||
5 | Date: Thu May 22 10:59:33 2014 +0100 | ||
6 | |||
7 | binconfig-disabled: Add class and use | ||
8 | |||
9 | diff --git a/configure.in b/configure.in | ||
10 | index 408e8d6..5f9e730 100644 | ||
11 | --- a/configure.in | ||
12 | +++ b/configure.in | ||
13 | @@ -86,39 +86,11 @@ case "$host" in | ||
14 | esac | ||
15 | AM_CONDITIONAL(USE_VERSION_RC, test x$use_version_rc = xtrue) | ||
16 | |||
17 | -dnl Check for the FreeType 2 library | ||
18 | -dnl | ||
19 | -dnl Get the cflags and libraries from the freetype-config script | ||
20 | -dnl | ||
21 | -AC_ARG_WITH(freetype-prefix,[ --with-freetype-prefix=PFX Prefix where FREETYPE is | ||
22 | -installed (optional)], | ||
23 | - freetype_prefix="$withval", freetype_prefix="") | ||
24 | -AC_ARG_WITH(freetype-exec-prefix,[ --with-freetype-exec-prefix=PFX Exec prefix | ||
25 | -where FREETYPE is installed (optional)], | ||
26 | - freetype_exec_prefix="$withval", freetype_exec_prefix="") | ||
27 | - | ||
28 | -if test x$freetype_exec_prefix != x ; then | ||
29 | - freetype_args="$freetype_args --exec-prefix=$freetype_exec_prefix" | ||
30 | - if test x${FREETYPE_CONFIG+set} != xset ; then | ||
31 | - FREETYPE_CONFIG=$freetype_exec_prefix/bin/freetype-config | ||
32 | - fi | ||
33 | -fi | ||
34 | -if test x$freetype_prefix != x ; then | ||
35 | - freetype_args="$freetype_args --prefix=$freetype_prefix" | ||
36 | - if test x${FREETYPE_CONFIG+set} != xset ; then | ||
37 | - FREETYPE_CONFIG=$freetype_prefix/bin/freetype-config | ||
38 | - fi | ||
39 | -fi | ||
40 | -AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no) | ||
41 | -no_freetype="" | ||
42 | -if test "$FREETYPE_CONFIG" = "no" ; then | ||
43 | - AC_MSG_ERROR([ | ||
44 | -*** Unable to find FreeType2 library (http://www.freetype.org/) | ||
45 | -]) | ||
46 | -else | ||
47 | - CFLAGS="$CFLAGS `$FREETYPE_CONFIG $freetypeconf_args --cflags`" | ||
48 | - LIBS="$LIBS `$FREETYPE_CONFIG $freetypeconf_args --libs`" | ||
49 | -fi | ||
50 | +PKG_CHECK_MODULES(FREETYPE2, freetype2, | ||
51 | + CFLAGS="$CFLAGS $FREETYPE2_CFLAGS" | ||
52 | + LIBS="$LIBS $FREETYPE2_LIBS", | ||
53 | + AC_MSG_ERROR([*** Unable to find FreeType2 library (http://www.freetype.org/)]) | ||
54 | +) | ||
55 | |||
56 | dnl Check for SDL | ||
57 | SDL_VERSION=2.0.0 | ||
diff --git a/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb index 0127b3181..47026a236 100644 --- a/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb +++ b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb | |||
@@ -8,6 +8,7 @@ PR = "r2" | |||
8 | 8 | ||
9 | SRC_URI = "http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-${PV}.tar.gz \ | 9 | SRC_URI = "http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-${PV}.tar.gz \ |
10 | file://configure.patch \ | 10 | file://configure.patch \ |
11 | file://use.pkg-config.for.freetype2.patch \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | S = "${WORKDIR}/SDL_ttf-${PV}" | 14 | S = "${WORKDIR}/SDL_ttf-${PV}" |