summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libsdl-ttf
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/libsdl-ttf
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/libsdl-ttf')
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/configure.patch52
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/use.pkg-config.for.freetype2.patch57
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb33
3 files changed, 142 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/configure.patch b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/configure.patch
new file mode 100644
index 000000000..de88f0a34
--- /dev/null
+++ b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/configure.patch
@@ -0,0 +1,52 @@
1Index: SDL_ttf-2.0.10/configure.in
2===================================================================
3--- SDL_ttf-2.0.10.orig/configure.in 2009-10-12 23:06:38.000000000 +0000
4+++ SDL_ttf-2.0.10/configure.in 2014-07-17 12:33:34.011662505 +0000
5@@ -1,5 +1,4 @@
6 dnl Process this file with autoconf to produce a configure script.
7-AC_INIT(README)
8
9 dnl Set various version strings - taken gratefully from the GTk sources
10
11@@ -11,12 +10,19 @@
12 # if backwards compatibility has been broken,
13 # set BINARY_AGE and INTERFACE_AGE to 0.
14
15-MAJOR_VERSION=2
16-MINOR_VERSION=0
17-MICRO_VERSION=10
18+m4_define([sdlttf_major_version],[2])
19+m4_define([sdlttf_minor_version],[0])
20+m4_define([sdlttf_micro_version],[10])
21+m4_define([sdlttf_version], [sdlttf_major_version.sdlttf_minor_version.sdlttf_micro_version])
22+
23+AC_INIT([SDL_ttf], [sdlttf_version])
24+
25+MAJOR_VERSION=sdlttf_major_version
26+MINOR_VERSION=sdlttf_minor_version
27+MICRO_VERSION=sdlttf_micro_version
28 INTERFACE_AGE=0
29 BINARY_AGE=10
30-VERSION=$MAJOR_VERSION.$MINOR_VERSION.$MICRO_VERSION
31+VERSION=sdlttf_version
32
33 AC_SUBST(MAJOR_VERSION)
34 AC_SUBST(MINOR_VERSION)
35@@ -25,6 +31,8 @@
36 AC_SUBST(BINARY_AGE)
37 AC_SUBST(VERSION)
38
39+AC_CONFIG_MACRO_DIR([acinclude])
40+
41 # libtool versioning
42 LT_INIT([win32-dll])
43
44@@ -42,7 +50,7 @@
45 AC_CANONICAL_HOST
46
47 dnl Setup for automake
48-AM_INIT_AUTOMAKE(SDL_ttf, $VERSION)
49+AM_INIT_AUTOMAKE([foreign])
50
51 dnl Check for tools
52 AC_PROG_LIBTOOL
diff --git a/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/use.pkg-config.for.freetype2.patch b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/use.pkg-config.for.freetype2.patch
new file mode 100644
index 000000000..8a11f6649
--- /dev/null
+++ b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf-2.0.10/use.pkg-config.for.freetype2.patch
@@ -0,0 +1,57 @@
1freetype-config was removed from oe-core in
2
3commit 5870bd272b0b077d0826fb900b251884c1c05061
4Author: Richard Purdie <richard.purdie@linuxfoundation.org>
5Date: Thu May 22 10:59:33 2014 +0100
6
7 binconfig-disabled: Add class and use
8
9diff --git a/configure.in b/configure.in
10index 408e8d6..5f9e730 100644
11--- a/configure.in
12+++ b/configure.in
13@@ -86,39 +86,11 @@ case "$host" in
14 esac
15 AM_CONDITIONAL(USE_VERSION_RC, test x$use_version_rc = xtrue)
16
17-dnl Check for the FreeType 2 library
18-dnl
19-dnl Get the cflags and libraries from the freetype-config script
20-dnl
21-AC_ARG_WITH(freetype-prefix,[ --with-freetype-prefix=PFX Prefix where FREETYPE is
22-installed (optional)],
23- freetype_prefix="$withval", freetype_prefix="")
24-AC_ARG_WITH(freetype-exec-prefix,[ --with-freetype-exec-prefix=PFX Exec prefix
25-where FREETYPE is installed (optional)],
26- freetype_exec_prefix="$withval", freetype_exec_prefix="")
27-
28-if test x$freetype_exec_prefix != x ; then
29- freetype_args="$freetype_args --exec-prefix=$freetype_exec_prefix"
30- if test x${FREETYPE_CONFIG+set} != xset ; then
31- FREETYPE_CONFIG=$freetype_exec_prefix/bin/freetype-config
32- fi
33-fi
34-if test x$freetype_prefix != x ; then
35- freetype_args="$freetype_args --prefix=$freetype_prefix"
36- if test x${FREETYPE_CONFIG+set} != xset ; then
37- FREETYPE_CONFIG=$freetype_prefix/bin/freetype-config
38- fi
39-fi
40-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
41-no_freetype=""
42-if test "$FREETYPE_CONFIG" = "no" ; then
43- AC_MSG_ERROR([
44-*** Unable to find FreeType2 library (http://www.freetype.org/)
45-])
46-else
47- CFLAGS="$CFLAGS `$FREETYPE_CONFIG $freetypeconf_args --cflags`"
48- LIBS="$LIBS `$FREETYPE_CONFIG $freetypeconf_args --libs`"
49-fi
50+PKG_CHECK_MODULES(FREETYPE2, freetype2,
51+ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
52+ LIBS="$LIBS $FREETYPE2_LIBS",
53+ AC_MSG_ERROR([*** Unable to find FreeType2 library (http://www.freetype.org/)])
54+)
55
56 dnl Check for SDL
57 SDL_VERSION=2.0.0
diff --git a/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb
new file mode 100644
index 000000000..ad3792e22
--- /dev/null
+++ b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Simple DirectMedia Layer truetype font library"
2SECTION = "libs"
3DEPENDS = "virtual/libsdl freetype"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
6
7PR = "r2"
8
9SRC_URI = "http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-${PV}.tar.gz \
10 file://configure.patch \
11 file://use.pkg-config.for.freetype2.patch \
12"
13
14S = "${WORKDIR}/SDL_ttf-${PV}"
15EXTRA_OECONF += "SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config "
16
17inherit autotools
18
19TARGET_CC_ARCH += "${LDFLAGS}"
20
21do_configure_prepend() {
22
23 # Removing these files fixes a libtool version mismatch.
24 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
25
26 for i in ${MACROS}; do
27 rm -f ${S}/acinclude/$i
28 done
29
30}
31
32SRC_URI[md5sum] = "814e6e17e8879254208d23b3b7e0354b"
33SRC_URI[sha256sum] = "7d38704bcc7c34029c2dcb73b2d4857e8ad76341c6e0faed279eb9f743c66c6a"