summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb')
-rw-r--r--meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb
new file mode 100644
index 000000000..ad3792e22
--- /dev/null
+++ b/meta-oe/recipes-support/libsdl-ttf/libsdl-ttf_2.0.10.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Simple DirectMedia Layer truetype font library"
2SECTION = "libs"
3DEPENDS = "virtual/libsdl freetype"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
6
7PR = "r2"
8
9SRC_URI = "http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-${PV}.tar.gz \
10 file://configure.patch \
11 file://use.pkg-config.for.freetype2.patch \
12"
13
14S = "${WORKDIR}/SDL_ttf-${PV}"
15EXTRA_OECONF += "SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config "
16
17inherit autotools
18
19TARGET_CC_ARCH += "${LDFLAGS}"
20
21do_configure_prepend() {
22
23 # Removing these files fixes a libtool version mismatch.
24 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
25
26 for i in ${MACROS}; do
27 rm -f ${S}/acinclude/$i
28 done
29
30}
31
32SRC_URI[md5sum] = "814e6e17e8879254208d23b3b7e0354b"
33SRC_URI[sha256sum] = "7d38704bcc7c34029c2dcb73b2d4857e8ad76341c6e0faed279eb9f743c66c6a"