summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.69.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-01-16 16:00:26 +0800
committerKhem Raj <raj.khem@gmail.com>2020-01-16 07:44:40 -0800
commit3e3088720ce02407f56388abbd941369e0c5c532 (patch)
tree143aee1aee06ead936f12edd5f4eb7cd1c4f5705 /meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.69.bb
parentc18278bc04ce03e00fdbf5587dff5e05c958fe53 (diff)
downloadmeta-openembedded-3e3088720ce02407f56388abbd941369e0c5c532.tar.gz
libmicrohttpd: upgrade 0.9.68 -> 0.9.69
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.69.bb')
-rw-r--r--meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.69.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.69.bb b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.69.bb
new file mode 100644
index 000000000..4daeaf75b
--- /dev/null
+++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.69.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
5SECTION = "net"
6
7DEPENDS = "file"
8
9SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz \
10"
11SRC_URI[md5sum] = "3ce03db1f10007517cecf05e040069af"
12SRC_URI[sha256sum] = "fb9b6b148b787493e637d3083588711e65cbcb726fa02cee2cd543c5de27e37e"
13
14inherit autotools lib_package pkgconfig gettext
15
16CFLAGS += "-pthread -D_REENTRANT"
17
18EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
19
20PACKAGECONFIG ?= "curl https"
21PACKAGECONFIG_append_class-target = "\
22 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
23"
24PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
25PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
26PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
27
28do_compile_append() {
29 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
30}