summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb')
-rw-r--r--meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb
new file mode 100644
index 000000000..e3c833bf4
--- /dev/null
+++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5SECTION = "net"
6DEPENDS = "libgcrypt gnutls file"
7
8SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9SRC_URI[md5sum] = "2947eee13c2c8affb95023a0cb6fda0c"
10SRC_URI[sha256sum] = "29a2bfd4fd2ddf60c756b8c283291a134898e3cc143843be421a040be1b25a88"
11
12inherit autotools lib_package
13
14# disable spdy, because it depends on openssl
15EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../ --disable-spdy"
16
17PACKAGECONFIG ?= "curl"
18PACKAGECONFIG_append_class-target = "\
19 ${@base_contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
20"
21PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
22PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
23
24do_compile_append() {
25 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
26}
27