summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2021-06-02 16:14:56 +0200
committerKhem Raj <raj.khem@gmail.com>2021-06-04 07:08:13 -0700
commit2d163d0e1857bf11e8518312fe759dbe5cc59a0b (patch)
treedd6f083b2fa530d040b11fbd72302ef14eb150ec /meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
parent1b26441296f942bcebbc48a23148b44bc0340bb5 (diff)
downloadmeta-openembedded-2d163d0e1857bf11e8518312fe759dbe5cc59a0b.tar.gz
libgpiod: correctly split output files into packages
Currently, the files that should go into libgpiod-ptest are part of either the main library package of libgpiod-tools. Use more fine-grained values for package files variables. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
index 43264782e..9e4bef7b4 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
@@ -28,7 +28,21 @@ EXTRA_OECONF = "--enable-tools"
28DEPENDS += "autoconf-archive-native" 28DEPENDS += "autoconf-archive-native"
29 29
30PACKAGES =+ "${PN}-tools libgpiodcxx ${PN}-python" 30PACKAGES =+ "${PN}-tools libgpiodcxx ${PN}-python"
31FILES_${PN}-tools = "${bindir}/*" 31FILES_${PN}-tools = " \
32 ${bindir}/gpiodetect \
33 ${bindir}/gpioinfo \
34 ${bindir}/gpioget \
35 ${bindir}/gpioset \
36 ${bindir}/gpiofind \
37 ${bindir}/gpiomon \
38"
39FILES_${PN}-ptest += " \
40 ${bindir}/gpiod-test \
41 ${bindir}/gpio-tools-test \
42 ${bindir}/gpio-tools-test.bats \
43 ${bindir}/gpiod-cxx-test \
44 ${libdir}/libgpiomockup.so.* \
45"
32FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*" 46FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*"
33FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*.so" 47FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*.so"
34FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a" 48FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"