summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libftdi
diff options
context:
space:
mode:
authorRaphael Silva <rapphil@gmail.com>2014-12-07 23:23:16 -0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-10 13:33:29 +0100
commitdc794a8570b57abd3ce2f8fc2014ca7cc64ac093 (patch)
tree63958be247d5550612b94adb0f6c6177aaa9d6dd /meta-oe/recipes-support/libftdi
parent66712383d64b76c4737a3e3725db6df944e1e78e (diff)
downloadmeta-openembedded-dc794a8570b57abd3ce2f8fc2014ca7cc64ac093.tar.gz
libftdi: update to 1.1
Previous version was 0.19 but it had a failing recipe due to the fact that libusb was not detect during do_configure. This problem does not happen in version 1.1. Signed-off-by: Mario Goulart <mario.goulart@gmail.com> Signed-off-by: Raphael Silva <rapphil@gmail.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libftdi')
-rw-r--r--meta-oe/recipes-support/libftdi/libftdi_0.19.bb31
-rw-r--r--meta-oe/recipes-support/libftdi/libftdi_1.1.bb29
2 files changed, 29 insertions, 31 deletions
diff --git a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb b/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
deleted file mode 100644
index 773b791f4..000000000
--- a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1DESCRIPTION = "libftdi is a library to talk to FTDI chips.\
2FT232BM/245BM, FT2232C/D and FT232/245R using libusb,\
3including the popular bitbang mode."
4HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
5SECTION = "libs"
6
7PR = "r1"
8
9LICENSE = "LGPLv2.1 GPLv2"
10LIC_FILES_CHKSUM= "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
11 file://COPYING.LIB;md5=db979804f025cf55aabec7129cb671ed \
12"
13
14PNBLACKLIST[libftdi] = "BROKEN: needs to be updated to detect libusb with pkg-config instead of libusb-config"
15
16DEPENDS = "virtual/libusb0"
17DEPENDS_virtclass-native = "virtual/libusb0-native"
18
19SRC_URI = "http://www.intra2net.com/en/developer/libftdi/download/libftdi-${PV}.tar.gz \
20 file://libtool-m4.patch \
21"
22SRC_URI[md5sum] = "e6e25f33b4327b1b7aa1156947da45f3"
23SRC_URI[sha256sum] = "567c9d2c42d92fc401c5aba2deed45ffb2433990984e816bcdf31e441aef06be"
24
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[cpp-wrapper] = "--enable-libftdipp,--disable-libftdipp,boost"
27
28inherit autotools binconfig pkgconfig
29
30BBCLASSEXTEND = "native"
31
diff --git a/meta-oe/recipes-support/libftdi/libftdi_1.1.bb b/meta-oe/recipes-support/libftdi/libftdi_1.1.bb
new file mode 100644
index 000000000..641e5a71b
--- /dev/null
+++ b/meta-oe/recipes-support/libftdi/libftdi_1.1.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "libftdi is a library to talk to FTDI chips.\
2FT232BM/245BM, FT2232C/D and FT232/245R using libusb,\
3including the popular bitbang mode."
4HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
5SECTION = "libs"
6
7LICENSE = "LGPLv2.1 GPLv2"
8LIC_FILES_CHKSUM= "\
9 file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
10 file://COPYING.LIB;md5=db979804f025cf55aabec7129cb671ed \
11"
12
13DEPENDS = "libusb1"
14
15SRC_URI = "http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2"
16
17SRC_URI[md5sum] = "b79a6356978aa8e69f8eecc3a720ff79"
18SRC_URI[sha256sum] = "c0b1af1a13e2c6682a1d8041e5b164a1e0d90267cd378bb51e059bd62f821e21"
19
20S = "${WORKDIR}/${BPN}1-${PV}"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[cpp-wrapper] = "-DFTDI_BUILD_CPP=on,-DFTDI_BUILD_CPP=off,boost"
24
25inherit cmake binconfig pkgconfig
26
27FILES_${PN}-dev += "${libdir}/cmake"
28
29BBCLASSEXTEND = "native"