summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libftdi/libftdi_1.2.bb
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2015-09-17 15:58:51 +1000
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-23 15:40:40 +0200
commit805cae56ddab596ab11840f494639888c528d3da (patch)
treea83f3cb6cf0951b6e71313c33ad532d42234e5dd /meta-oe/recipes-support/libftdi/libftdi_1.2.bb
parenta01fd273804b31b22f5b9686706cefa62720081e (diff)
downloadmeta-openembedded-805cae56ddab596ab11840f494639888c528d3da.tar.gz
libftdi: update to 1.2
Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libftdi/libftdi_1.2.bb')
-rw-r--r--meta-oe/recipes-support/libftdi/libftdi_1.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libftdi/libftdi_1.2.bb b/meta-oe/recipes-support/libftdi/libftdi_1.2.bb
new file mode 100644
index 000000000..eb4d86c3b
--- /dev/null
+++ b/meta-oe/recipes-support/libftdi/libftdi_1.2.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "libftdi is a library to talk to FTDI chips.\
2FT232BM/245BM, FT2232C/D and FT232/245R using libusb,\
3including the popular bitbang mode."
4HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
5SECTION = "libs"
6
7LICENSE = "LGPLv2.1 & GPLv2"
8LIC_FILES_CHKSUM= "\
9 file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
10 file://COPYING.LIB;md5=db979804f025cf55aabec7129cb671ed \
11"
12
13DEPENDS = "libusb1"
14
15SRC_URI = "http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2"
16
17SRC_URI[md5sum] = "89dff802d89c4c0d55d8b4665fd52d0b"
18SRC_URI[sha256sum] = "a6ea795c829219015eb372b03008351cee3fb39f684bff3bf8a4620b558488d6"
19
20S = "${WORKDIR}/${BPN}1-${PV}"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[cpp-wrapper] = "-DFTDI_BUILD_CPP=on,-DFTDI_BUILD_CPP=off,boost"
24
25inherit cmake binconfig pkgconfig
26
27EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"
28
29FILES_${PN}-dev += "${libdir}/cmake"
30
31BBCLASSEXTEND = "native"