summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libetpan
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/libetpan
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/libetpan')
-rw-r--r--meta-oe/recipes-support/libetpan/libetpan-0.57/libetpan-autoreconf.patch12
-rw-r--r--meta-oe/recipes-support/libetpan/libetpan-0.57/libetpan-ldflags.patch11
-rw-r--r--meta-oe/recipes-support/libetpan/libetpan-0.57/sepbuild.patch16
-rw-r--r--meta-oe/recipes-support/libetpan/libetpan_0.57.bb27
4 files changed, 66 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libetpan/libetpan-0.57/libetpan-autoreconf.patch b/meta-oe/recipes-support/libetpan/libetpan-0.57/libetpan-autoreconf.patch
new file mode 100644
index 000000000..d05967da3
--- /dev/null
+++ b/meta-oe/recipes-support/libetpan/libetpan-0.57/libetpan-autoreconf.patch
@@ -0,0 +1,12 @@
1Index: libetpan-0.57/configure.ac
2===================================================================
3--- libetpan-0.57.orig/configure.ac 2008-10-08 19:54:20.000000000 +0000
4+++ libetpan-0.57/configure.ac 2008-11-11 16:34:33.000000000 +0000
5@@ -106,6 +106,7 @@
6
7 # Check the C compiler.
8 AC_PROG_CC
9+AC_PROG_CXX
10
11 # Compiler flags.
12 AC_ARG_ENABLE(debug, [ --enable-debug setup flags (gcc) for debugging (default=no)],
diff --git a/meta-oe/recipes-support/libetpan/libetpan-0.57/libetpan-ldflags.patch b/meta-oe/recipes-support/libetpan/libetpan-0.57/libetpan-ldflags.patch
new file mode 100644
index 000000000..438f44f15
--- /dev/null
+++ b/meta-oe/recipes-support/libetpan/libetpan-0.57/libetpan-ldflags.patch
@@ -0,0 +1,11 @@
1--- libetpan-0.57/configure.ac~ 2009-09-21 23:31:42.000000000 +0200
2+++ libetpan-0.57/configure.ac 2009-09-21 23:31:42.000000000 +0200
3@@ -457,7 +457,7 @@
4 LDFLAGS="-$flag $LDFLAGS"
5 AC_TRY_LINK([], [pthread_create();],
6 [pthflag=yes; checkpthread=no],
7- [pthflag=no; LDFLAGS="$OLDCFLAGS"])
8+ [pthflag=no; LDFLAGS="$OLDFLAGS"])
9 AC_MSG_RESULT($pthflag)
10 fi
11 done
diff --git a/meta-oe/recipes-support/libetpan/libetpan-0.57/sepbuild.patch b/meta-oe/recipes-support/libetpan/libetpan-0.57/sepbuild.patch
new file mode 100644
index 000000000..4f0161727
--- /dev/null
+++ b/meta-oe/recipes-support/libetpan/libetpan-0.57/sepbuild.patch
@@ -0,0 +1,16 @@
1Index: libetpan-0.57/rules.mk
2===================================================================
3--- libetpan-0.57.orig/rules.mk
4+++ libetpan-0.57/rules.mk
5@@ -134,9 +134,9 @@ prepare-am: prepare-local
6 if test -e ../../$(subdir)/$${hdr}; then \
7 echo "$(LN_S) -f ../../$(subdir)/$${hdr} ."; \
8 $(LN_S) -f ../../$(subdir)/$${hdr} .; \
9 else \
10- echo "$(LN_S) -f ../../$(subdir)/$(srcdir)/$${hdr} ."; \
11- $(LN_S) -f ../../$(subdir)/$(srcdir)/$${hdr} .; \
12+ echo "$(LN_S) -f $(srcdir)/$${hdr} ."; \
13+ $(LN_S) -f $(srcdir)/$${hdr} .; \
14 fi; \
15 fi; \
16 done; \
diff --git a/meta-oe/recipes-support/libetpan/libetpan_0.57.bb b/meta-oe/recipes-support/libetpan/libetpan_0.57.bb
new file mode 100644
index 000000000..6be0694ef
--- /dev/null
+++ b/meta-oe/recipes-support/libetpan/libetpan_0.57.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "libetpan is a library for communicating with mail and news servers. \
2It supports the protocols SMTP, POP3, IMAP and NNTP."
3HOMEPAGE = "http://www.etpan.org"
4SECTION = "libs"
5DEPENDS = "gnutls liblockfile curl"
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=f18ebe7e452708c26f83954f81062ba7"
8
9PR = "r1"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
12 file://libetpan-autoreconf.patch \
13 file://libetpan-ldflags.patch \
14 file://sepbuild.patch"
15
16inherit autotools pkgconfig gettext binconfig
17
18EXTRA_OECONF = "--without-openssl --without-sasl --with-gnutls --disable-db"
19
20PARALLEL_MAKE = ""
21
22FILES_${PN} = "${libdir}/lib*.so.*"
23FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"
24
25
26SRC_URI[md5sum] = "8ce8c6c071e81884a475b12b7f9a9cc0"
27SRC_URI[sha256sum] = "1f3fda5c9e2961d1a6298dc8aadae321493d37727d8db45bc2e8d58f20547011"