summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libee
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/libee
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/libee')
-rw-r--r--meta-oe/recipes-support/libee/libee.inc39
-rwxr-xr-xmeta-oe/recipes-support/libee/libee/ezapi1.sh14
-rw-r--r--meta-oe/recipes-support/libee/libee/libee-parallel-make.patch20
-rwxr-xr-xmeta-oe/recipes-support/libee/libee/run-ptest3
-rw-r--r--meta-oe/recipes-support/libee/libee_0.4.1.bb4
5 files changed, 80 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libee/libee.inc b/meta-oe/recipes-support/libee/libee.inc
new file mode 100644
index 000000000..5b552ca2a
--- /dev/null
+++ b/meta-oe/recipes-support/libee/libee.inc
@@ -0,0 +1,39 @@
1SUMMARY = "An Event Expression Library inspired by CEE"
2DESCRIPTION = "The core idea of libee is to provide a small \
3but hopefully convenient API layer above the CEE standard."
4
5HOMEPAGE = "http://www.libee.org"
6SECTION = "base"
7
8LICENSE = "LGPL-2.1+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=1c2687de35e36ba3b999136236a66cd6"
10
11SRC_URI = "http://www.libee.org/download/files/download/${BPN}-${PV}.tar.gz\
12 file://libee-parallel-make.patch \
13 file://run-ptest \
14 file://ezapi1.sh \
15"
16
17inherit autotools ptest pkgconfig
18
19DEPENDS += "libestr"
20
21PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'ptest', 'testbench', '', d)}"
22
23PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
24PACKAGECONFIG[testbench] = "--enable-testbench,--disable-testbench,,"
25
26TESTDIR = "tests"
27
28# We presume the tests we are going to install so just build them directly.
29#
30do_compile_ptest() {
31 oe_runmake -C ${TESTDIR} genfile ezapi1
32}
33
34do_install_ptest() {
35 install -d ${D}${PTEST_PATH}
36 install -m 0755 ${B}/${TESTDIR}/genfile ${D}${PTEST_PATH}
37 install -m 0755 ${B}/${TESTDIR}/.libs/ezapi1 ${D}${PTEST_PATH}
38 install -m 0755 ${WORKDIR}/ezapi1.sh ${D}${PTEST_PATH}
39}
diff --git a/meta-oe/recipes-support/libee/libee/ezapi1.sh b/meta-oe/recipes-support/libee/libee/ezapi1.sh
new file mode 100755
index 000000000..e9db5e614
--- /dev/null
+++ b/meta-oe/recipes-support/libee/libee/ezapi1.sh
@@ -0,0 +1,14 @@
1#!/bin/sh
2#
3echo ---------------------------------------------------------------------------
4echo A very basic test for the event class
5echo ---------------------------------------------------------------------------
6rm -f infile
7./genfile 100 > infile
8./ezapi1 -iinfile
9if [ $? -ne 0 ] ; then
10 echo "FAIL: $0"
11 exit 1
12fi
13echo "PASS: $0"
14rm -f infile
diff --git a/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch b/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch
new file mode 100644
index 000000000..25e5c6ae0
--- /dev/null
+++ b/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch
@@ -0,0 +1,20 @@
1fix parallel compiling problem
2
3without specifying libee_convert_DEPENDENCIES = libee.la, libee_convert
4can't find libee.la when linking as libee is not generated yet.
5
6Upstream-Status: pending
7
8Signed-off-by: Yao Zhao <yao.zhao@windriver.com>
9---
10diff --git a/src/Makefile.am b/src/Makefile.am
11index 08aaa9e..f0c78f7 100644
12--- a/src/Makefile.am
13+++ b/src/Makefile.am
14@@ -46,5 +46,6 @@ libee_la_LDFLAGS = -version-info 0:0:0
15 libee_convert_SOURCES = convert.c
16 libee_convert_CPPFLAGS = -I$(top_srcdir) $(LIBEE_CFLAGS) $(LIBESTR_CFLAGS) $(LIBXML2_CFLAGS)
17 libee_convert_LDADD = $(LIBEE_LIBS) $(LIBXML2_LIBS) $(LIBESTR_LIBS)
18+libee_convert_DEPENDENCIES = libee.la
19
20 include_HEADERS =
diff --git a/meta-oe/recipes-support/libee/libee/run-ptest b/meta-oe/recipes-support/libee/libee/run-ptest
new file mode 100755
index 000000000..3cb660764
--- /dev/null
+++ b/meta-oe/recipes-support/libee/libee/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2#
3./ezapi1.sh
diff --git a/meta-oe/recipes-support/libee/libee_0.4.1.bb b/meta-oe/recipes-support/libee/libee_0.4.1.bb
new file mode 100644
index 000000000..ef2c20db5
--- /dev/null
+++ b/meta-oe/recipes-support/libee/libee_0.4.1.bb
@@ -0,0 +1,4 @@
1require ${BPN}.inc
2
3SRC_URI[md5sum] = "7bbf4160876c12db6193c06e2badedb2"
4SRC_URI[sha256sum] = "c0dac01938593deee06c3d161e4eda4ecc0fd7317e1321bd96e301aceb7fb027"