summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libee/libee
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/libee/libee
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/libee/libee')
-rwxr-xr-xmeta-oe/recipes-support/libee/libee/ezapi1.sh14
-rw-r--r--meta-oe/recipes-support/libee/libee/libee-parallel-make.patch20
-rwxr-xr-xmeta-oe/recipes-support/libee/libee/run-ptest3
3 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libee/libee/ezapi1.sh b/meta-oe/recipes-support/libee/libee/ezapi1.sh
new file mode 100755
index 000000000..e9db5e614
--- /dev/null
+++ b/meta-oe/recipes-support/libee/libee/ezapi1.sh
@@ -0,0 +1,14 @@
1#!/bin/sh
2#
3echo ---------------------------------------------------------------------------
4echo A very basic test for the event class
5echo ---------------------------------------------------------------------------
6rm -f infile
7./genfile 100 > infile
8./ezapi1 -iinfile
9if [ $? -ne 0 ] ; then
10 echo "FAIL: $0"
11 exit 1
12fi
13echo "PASS: $0"
14rm -f infile
diff --git a/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch b/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch
new file mode 100644
index 000000000..25e5c6ae0
--- /dev/null
+++ b/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch
@@ -0,0 +1,20 @@
1fix parallel compiling problem
2
3without specifying libee_convert_DEPENDENCIES = libee.la, libee_convert
4can't find libee.la when linking as libee is not generated yet.
5
6Upstream-Status: pending
7
8Signed-off-by: Yao Zhao <yao.zhao@windriver.com>
9---
10diff --git a/src/Makefile.am b/src/Makefile.am
11index 08aaa9e..f0c78f7 100644
12--- a/src/Makefile.am
13+++ b/src/Makefile.am
14@@ -46,5 +46,6 @@ libee_la_LDFLAGS = -version-info 0:0:0
15 libee_convert_SOURCES = convert.c
16 libee_convert_CPPFLAGS = -I$(top_srcdir) $(LIBEE_CFLAGS) $(LIBESTR_CFLAGS) $(LIBXML2_CFLAGS)
17 libee_convert_LDADD = $(LIBEE_LIBS) $(LIBXML2_LIBS) $(LIBESTR_LIBS)
18+libee_convert_DEPENDENCIES = libee.la
19
20 include_HEADERS =
diff --git a/meta-oe/recipes-support/libee/libee/run-ptest b/meta-oe/recipes-support/libee/libee/run-ptest
new file mode 100755
index 000000000..3cb660764
--- /dev/null
+++ b/meta-oe/recipes-support/libee/libee/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2#
3./ezapi1.sh