summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libcanberra/libcanberra_0.29.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/libcanberra/libcanberra_0.29.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/libcanberra/libcanberra_0.29.bb')
-rw-r--r--meta-oe/recipes-support/libcanberra/libcanberra_0.29.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libcanberra/libcanberra_0.29.bb b/meta-oe/recipes-support/libcanberra/libcanberra_0.29.bb
new file mode 100644
index 000000000..0f00b209f
--- /dev/null
+++ b/meta-oe/recipes-support/libcanberra/libcanberra_0.29.bb
@@ -0,0 +1,62 @@
1SUMMARY = "Implementation of XDG Sound Theme and Name Specifications"
2DESCRIPTION = "Libcanberra is an implementation of the XDG Sound Theme and Name Specifications, for generating event sounds on free desktops."
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
5 file://src/canberra.h;beginline=7;endline=24;md5=c616c687cf8da540a14f917e0d23ab03"
6
7DEPENDS = "gstreamer gtk+ gtk+3 libtool libvorbis"
8
9inherit autotools gtk-doc
10
11SRC_URI = " \
12 http://0pointer.de/lennart/projects/${BPN}/${BPN}-${PV}.tar.xz \
13 file://0001-build-gtk-and-gtk3-version-for-canberra_gtk_play.patch \
14"
15SRC_URI[md5sum] = "2594093a5d61047bd9cc87e955f86df8"
16SRC_URI[sha256sum] = "127a5ef07805856d63758e5180ebfb241d1f80094fd301c287591a15b8cfcd72"
17
18EXTRA_OECONF = "\
19 --enable-null \
20 --enable-gstreamer \
21 --disable-oss \
22 --enable-gtk \
23 --enable-gtk3 \
24 --disable-tdb \
25 --disable-lynx \
26"
27
28PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES','alsa','alsa','',d)} \
29 ${@base_contains('DISTRO_FEATURES','pulseaudio','pulseaudio','',d)} \
30"
31PACKAGECONFIG[alsa] = "--enable-alsa, --disable-alsa, alsa-lib"
32PACKAGECONFIG[pulseaudio] = "--enable-pulse, --disable-pulse, pulseaudio"
33
34python populate_packages_prepend() {
35 plugindir = d.expand('${libdir}/${BPN}-${PV}/')
36 do_split_packages(d, plugindir, '^libcanberra-(.*)\.so$', 'libcanberra-%s', '%s support library', extra_depends='' )
37 do_split_packages(d, plugindir, '^libcanberra-(.*)\.la$', 'libcanberra-%s', '%s support library', extra_depends='' )
38}
39
40PACKAGES =+ "${PN}-gnome ${PN}-gtk2 ${PN}-gtk3 ${PN}-systemd"
41PACKAGES_DYNAMIC += "^libcanberra-.*"
42
43FILES_${PN} = "${bindir}/ ${libdir}/${BPN}.so.*"
44
45FILES_${PN}-dev += "${datadir}/vala/vapi ${libdir}/*/modules/*.la ${libdir}/*/*.la"
46
47FILES_${PN}-dbg += "${libdir}/${BPN}-${PV}/.debug ${libdir}/gtk-*/modules/.debug"
48
49FILES_${PN}-gtk2 = "${libdir}/${BPN}-gtk.so.* \
50 ${libdir}/gtk-2.0/modules/*.so \
51 ${bindir}/canberra-gtk-play"
52
53# -gtk3 ships a symlink to a .so
54INSANE_SKIP_${PN}-gtk3 = "dev-so"
55FILES_${PN}-gtk3 = "${libdir}/${BPN}-gtk3.so.* \
56 ${libdir}/gtk-3.0/modules/*.so \
57 ${bindir}/canberra-gtk3-play"
58
59FILES_${PN}-gnome = "${libdir}/gnome-settings-daemon-3.0/ \
60 ${datadir}/gdm/ ${datadir}/gnome/"
61
62FILES_${PN}-systemd = "${systemd_unitdir}/system/*.service"