summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libatasmart
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-09 19:54:28 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-09 20:02:17 +0200
commitb78c1baaff4e5d2f5ead8f6687bedb620b0fa690 (patch)
tree87674b38b0641edb593b8c3b5c2fa3d45a1b9b66 /meta-oe/recipes-support/libatasmart
parente7d41e49305cafcb4cfb7b6af2940573cee4fb51 (diff)
downloadmeta-openembedded-b78c1baaff4e5d2f5ead8f6687bedb620b0fa690.tar.gz
libatasmart: add 0.17
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/libatasmart')
-rw-r--r--meta-oe/recipes-support/libatasmart/libatasmart-0.17/strpool.patch11
-rw-r--r--meta-oe/recipes-support/libatasmart/libatasmart_0.17.bb17
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libatasmart/libatasmart-0.17/strpool.patch b/meta-oe/recipes-support/libatasmart/libatasmart-0.17/strpool.patch
new file mode 100644
index 000000000..e9f6ab31e
--- /dev/null
+++ b/meta-oe/recipes-support/libatasmart/libatasmart-0.17/strpool.patch
@@ -0,0 +1,11 @@
1--- git/Makefile.am.orig 2010-09-24 11:03:40.917602895 +0200
2+++ git/Makefile.am 2010-09-24 11:07:04.145852660 +0200
3@@ -81,5 +81,8 @@
4 BUILT_SOURCES = \
5 atasmart.strpool.c
6
7+strpool: $(strpool_SOURCES)
8+ $(BUILD_CC) -o $@ $?
9+
10 atasmart.strpool.c: atasmart.c strpool
11 $(top_builddir)/strpool $< $@
diff --git a/meta-oe/recipes-support/libatasmart/libatasmart_0.17.bb b/meta-oe/recipes-support/libatasmart/libatasmart_0.17.bb
new file mode 100644
index 000000000..c8f75f848
--- /dev/null
+++ b/meta-oe/recipes-support/libatasmart/libatasmart_0.17.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "ATA S.M.A.R.T. Reading and Parsing Library"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1"
4
5DEPENDS = "udev"
6
7SRCREV = "v${PV}"
8SRC_URI = "git://git.0pointer.de/libatasmart.git;protocol=git \
9 file://strpool.patch"
10
11S = "${WORKDIR}/git"
12
13inherit autotools lib_package
14
15do_install_append() {
16 sed -i -e s://:/:g -e 's:=${libdir}/libudev.la:-ludev:g' ${D}${libdir}/libatasmart.la
17}