diff options
author | Zhenhua Luo <b19537@freescale.com> | 2011-12-21 06:01:41 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-12-22 08:49:16 +0100 |
commit | 16da7fbd7b7a41c51e6c650e133f53b7210016e3 (patch) | |
tree | 8810ee0183bc7e12dcc4e91327aafe090c0d3d63 /meta-oe/recipes-support/ipsec-tools | |
parent | 8b08e151645d19d2940b6f83c7626087f4ac874f (diff) | |
download | meta-openembedded-16da7fbd7b7a41c51e6c650e133f53b7210016e3.tar.gz |
ipsec-tools: add version 0.7.2
IPsec-Tools is a port of KAME's IPsec utilities to the Linux IPsec
implementation.
Signed-off-by: Zhenhua Luo <b19537@freescale.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/ipsec-tools')
3 files changed, 72 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ipsec-tools/files/ipsec-tools-install.patch b/meta-oe/recipes-support/ipsec-tools/files/ipsec-tools-install.patch new file mode 100644 index 000000000..6b9c39b6d --- /dev/null +++ b/meta-oe/recipes-support/ipsec-tools/files/ipsec-tools-install.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | Taken from pld-linux.org: | ||
2 | http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/ipsec-tools/ipsec-tools-install.patch | ||
3 | |||
4 | --- ipsec-tools-0.7.2/src/racoon/Makefile.am~ 2008-07-23 13:48:40.000000000 +0200 | ||
5 | +++ ipsec-tools-0.7.2/src/racoon/Makefile.am 2009-07-04 01:43:48.148433975 +0200 | ||
6 | @@ -3,7 +3,7 @@ | ||
7 | sbin_PROGRAMS = racoon racoonctl plainrsa-gen | ||
8 | noinst_PROGRAMS = eaytest | ||
9 | include_racoon_HEADERS = racoonctl.h var.h vmbuf.h misc.h gcmalloc.h admin.h \ | ||
10 | - schedule.h sockmisc.h vmbuf.h isakmp_var.h isakmp.h isakmp_xauth.h \ | ||
11 | + schedule.h sockmisc.h isakmp_var.h isakmp.h isakmp_xauth.h \ | ||
12 | isakmp_cfg.h isakmp_unity.h ipsec_doi.h evt.h | ||
13 | lib_LTLIBRARIES = libracoon.la | ||
14 | |||
diff --git a/meta-oe/recipes-support/ipsec-tools/ipsec-tools.inc b/meta-oe/recipes-support/ipsec-tools/ipsec-tools.inc new file mode 100644 index 000000000..caf2b0b71 --- /dev/null +++ b/meta-oe/recipes-support/ipsec-tools/ipsec-tools.inc | |||
@@ -0,0 +1,51 @@ | |||
1 | DESCRIPTION = "IPsec-Tools is a port of KAME's IPsec utilities to the \ | ||
2 | Linux-2.6 IPsec implementation." | ||
3 | HOMEPAGE = "http://ipsec-tools.sourceforge.net/" | ||
4 | SECTION = "console/network" | ||
5 | LICENSE = "BSD" | ||
6 | DEPENDS = "virtual/kernel openssl readline flex" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/ipsec-tools/ipsec-tools-${PV}.tar.bz2;name=ipsec-tools-${PV}" | ||
9 | |||
10 | inherit autotools | ||
11 | |||
12 | # Options: | ||
13 | # --enable-adminport enable admin port | ||
14 | # --enable-rc5 enable RC5 encryption (patented) | ||
15 | # --enable-idea enable IDEA encryption (patented) | ||
16 | # --enable-gssapi enable GSS-API authentication | ||
17 | # --enable-hybrid enable hybrid, both mode-cfg and xauth support | ||
18 | # --enable-frag enable IKE fragmentation payload support | ||
19 | # --enable-stats enable statistics logging function | ||
20 | # --enable-dpd enable dead peer detection | ||
21 | # --enable-samode-unspec enable to use unspecified a mode of SA | ||
22 | # --disable-ipv6 disable ipv6 support | ||
23 | # --enable-natt enable NAT-Traversal (yes/no/kernel) | ||
24 | # --enable-natt-versions=list list of supported NAT-T versions delimited by coma. | ||
25 | # --with-kernel-headers=/lib/modules/<uname>/build/include | ||
26 | # where your Linux Kernel headers are installed | ||
27 | # --with-readline support readline input (yes by default) | ||
28 | # --with-flex use directiory (default: no) | ||
29 | # --with-flexlib=<LIB> specify flex library. | ||
30 | # --with-openssl=DIR specify OpenSSL directory | ||
31 | # --with-libradius=DIR specify libradius path (like/usr/pkg) | ||
32 | # --with-libpam=DIR specify libpam path (like/usr/pkg) | ||
33 | # | ||
34 | # Note: if you give it the actual kernel headers it won't build, it actually | ||
35 | # needs to point at the linux-libc-headers version of the kernel headers. | ||
36 | # | ||
37 | EXTRA_OECONF = "--with-kernel-headers=${STAGING_INCDIR} \ | ||
38 | --with-readline \ | ||
39 | --with-openssl=${STAGING_LIBDIR}/.. \ | ||
40 | --without-libradius \ | ||
41 | --without-gssapi \ | ||
42 | --without-libpam \ | ||
43 | --disable-security-context" | ||
44 | |||
45 | # See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530527 | ||
46 | CFLAGS += "-fno-strict-aliasing" | ||
47 | |||
48 | # Sometimes it attempts to use y.tab.c before it is actually | ||
49 | # generated. Note that the failure case is very rare, but it does | ||
50 | # happen. | ||
51 | PARALLEL_MAKE = "" | ||
diff --git a/meta-oe/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb b/meta-oe/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb new file mode 100644 index 000000000..270d77eb5 --- /dev/null +++ b/meta-oe/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | require ipsec-tools.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://Makefile.in;endline=14;md5=c73d05590728997bfbab5c671ed38366" | ||
4 | |||
5 | SRC_URI += "file://ipsec-tools-install.patch" | ||
6 | SRC_URI[ipsec-tools-0.7.2.md5sum] = "72861f005746ee27984b2ee715ecc629" | ||
7 | SRC_URI[ipsec-tools-0.7.2.sha256sum] = "08722ff6c62de3e042fef337454f03622a79053108d6dcc686c9c854f9f9e031" | ||