summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/imagemagick
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/imagemagick
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/imagemagick')
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick_6.8.9.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_6.8.9.bb b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.9.bb
new file mode 100644
index 000000000..7cb8f0189
--- /dev/null
+++ b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.9.bb
@@ -0,0 +1,41 @@
1SUMMARY = "ImageMagick is an image convertion tools"
2SECTION = "console/utils"
3LICENSE = "ImageMagick"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5d84c6ddd4028aa53d028b4c50f9361e"
5# FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
6DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib virtual/fftw freetype"
7
8PATCHSET = "8"
9SRC_URI = "http://www.imagemagick.org/download/releases/ImageMagick-${PV}-${PATCHSET}.tar.bz2 \
10"
11SRC_URI[md5sum] = "7e96f55156d72ce59c76ec93362ec72a"
12SRC_URI[sha256sum] = "51e0eb0b56e2f16be11c29086a97d474ffd07fe4eb5a9858d8a9c8e9c054c99a"
13
14S = "${WORKDIR}/ImageMagick-${PV}-${PATCHSET}"
15
16inherit autotools pkgconfig
17
18# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
19# if someone needs xml support then fix it first
20EXTRA_OECONF = "--program-prefix= --program-suffix=.im6 --without-x --without-perl --disable-openmp --without-xml --disable-opencl"
21
22CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[jp2] = "--with-jp2,,jasper"
25PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
26PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo"
27PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
28PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf"
29
30FILES_${PN} += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.so \
31 ${libdir}/ImageMagick-${PV}/modules-Q16/*/*.la \
32 ${libdir}/ImageMagick-${PV}/modules-Q16/filters \
33 ${libdir}/ImageMagick-${PV}/modules-Q16/coders \
34 ${libdir}/ImageMagick-${PV}/config-Q16 \
35 ${datadir}/ImageMagick-6 "
36
37FILES_${PN}-dev += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.a"
38
39FILES_${PN}-dbg += "${libdir}/ImageMagick-${PV}/modules-Q16/*/.debug/*"
40
41BBCLASSEXTEND = "native"