summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/iksemel
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/iksemel
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/iksemel')
-rw-r--r--meta-oe/recipes-support/iksemel/iksemel-1.4/r25.diff32
-rw-r--r--meta-oe/recipes-support/iksemel/iksemel_1.4.bb16
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/iksemel/iksemel-1.4/r25.diff b/meta-oe/recipes-support/iksemel/iksemel-1.4/r25.diff
new file mode 100644
index 000000000..e666ce07b
--- /dev/null
+++ b/meta-oe/recipes-support/iksemel/iksemel-1.4/r25.diff
@@ -0,0 +1,32 @@
1Taken from upstream subversion repository:
2
3http://code.google.com/p/iksemel/source/detail?r=25
4
5===================================================================
6---
7 configure.ac | 10 +++++++++-
8 1 file changed, 9 insertions(+), 1 deletion(-)
9
10--- iksemel-1.4.orig/configure.ac
11+++ iksemel-1.4/configure.ac
12@@ -43,11 +43,19 @@ AM_CONDITIONAL(DO_POSIX, test "x$defio"
13 dnl Checks for library functions
14 AC_SEARCH_LIBS(recv,socket)
15 AC_CHECK_FUNCS(getopt_long)
16 AC_CHECK_FUNCS(getaddrinfo)
17
18-AM_PATH_LIBGNUTLS(,AC_DEFINE(HAVE_GNUTLS,,"Use libgnutls"))
19+dnl Check GNU TLS
20+PKG_CHECK_MODULES(GNUTLS, gnutls >= 2.0.0, have_gnutls=yes, have_gnutls=no)
21+if test "x$have_gnutls" = "xyes"; then
22+ LIBGNUTLS_CFLAGS="$GNUTLS_CFLAGS"
23+ LIBGNUTLS_LIBS="$GNUTLS_LIBS"
24+ AC_SUBST(LIBGNUTLS_CFLAGS)
25+ AC_SUBST(LIBGNUTLS_LIBS)
26+ AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])
27+fi
28
29 dnl Check -Wall flag of GCC
30 if test "x$GCC" = "xyes"; then
31 if test -z "`echo "$CFLAGS" | grep "\-Wall" 2> /dev/null`" ; then
32 CFLAGS="$CFLAGS -Wall"
diff --git a/meta-oe/recipes-support/iksemel/iksemel_1.4.bb b/meta-oe/recipes-support/iksemel/iksemel_1.4.bb
new file mode 100644
index 000000000..6d2abf7ce
--- /dev/null
+++ b/meta-oe/recipes-support/iksemel/iksemel_1.4.bb
@@ -0,0 +1,16 @@
1SUMMARY = "Fast and portable XML parser and Jabber protocol library"
2AUTHOR = "Gurer Ozen <meduketto at gmail.com>"
3HOMEPAGE = "http://iksemel.googlecode.com"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499"
7DEPENDS = "gnutls"
8
9PR = "r1"
10
11SRC_URI = "http://iksemel.googlecode.com/files/${BP}.tar.gz;name=archive \
12 file://r25.diff"
13SRC_URI[archive.md5sum] = "532e77181694f87ad5eb59435d11c1ca"
14SRC_URI[archive.sha256sum] = "458c1b8fb3349076a6cecf26c29db1d561315d84e16bfcfba419f327f502e244"
15
16inherit autotools pkgconfig