diff options
author | Darren Hart <dvhart@linux.intel.com> | 2014-07-21 16:37:46 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 12:10:30 +0200 |
commit | 321c808a57e657c857dfe412d3c09839ebac27f1 (patch) | |
tree | 41c6e7d9285f7bffaa363b227973662e8883535c /meta-oe/recipes-support/i2c-tools | |
parent | b4a886b52ab2323b078d66aaedc15c27f71b24ac (diff) | |
download | meta-openembedded-321c808a57e657c857dfe412d3c09839ebac27f1.tar.gz |
i2c-tools: Remove i2c-tools, it's now in oe-core
i2c-tools was added to oe-core in commit:
32ac58819580d359e22161be1abf62215d202250
Remove it from meta-openembedded.
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/i2c-tools')
-rw-r--r-- | meta-oe/recipes-support/i2c-tools/i2c-tools-3.1.0/Module.mk | 72 | ||||
-rw-r--r-- | meta-oe/recipes-support/i2c-tools/i2c-tools_3.1.0.bb | 26 |
2 files changed, 0 insertions, 98 deletions
diff --git a/meta-oe/recipes-support/i2c-tools/i2c-tools-3.1.0/Module.mk b/meta-oe/recipes-support/i2c-tools/i2c-tools-3.1.0/Module.mk deleted file mode 100644 index fcaf72f22..000000000 --- a/meta-oe/recipes-support/i2c-tools/i2c-tools-3.1.0/Module.mk +++ /dev/null | |||
@@ -1,72 +0,0 @@ | |||
1 | # EEPROMER | ||
2 | # | ||
3 | # Licensed under the GNU General Public License. | ||
4 | |||
5 | EEPROMER_DIR := eepromer | ||
6 | |||
7 | EEPROMER_CFLAGS := -Wstrict-prototypes -Wshadow -Wpointer-arith -Wcast-qual \ | ||
8 | -Wcast-align -Wwrite-strings -Wnested-externs -Winline \ | ||
9 | -W -Wundef -Wmissing-prototypes -Iinclude | ||
10 | |||
11 | EEPROMER_TARGETS := eepromer eeprom eeprog | ||
12 | |||
13 | # | ||
14 | # Programs | ||
15 | # | ||
16 | |||
17 | $(EEPROMER_DIR)/eepromer: $(EEPROMER_DIR)/eepromer.o | ||
18 | $(CC) $(LDFLAGS) -o $@ $^ | ||
19 | |||
20 | $(EEPROMER_DIR)/eeprom: $(EEPROMER_DIR)/eeprom.o | ||
21 | $(CC) $(LDFLAGS) -o $@ $^ | ||
22 | |||
23 | $(EEPROMER_DIR)/eeprog: $(EEPROMER_DIR)/eeprog.o $(EEPROMER_DIR)/24cXX.o | ||
24 | $(CC) $(LDFLAGS) -o $@ $^ | ||
25 | |||
26 | # | ||
27 | # Objects | ||
28 | # | ||
29 | |||
30 | $(EEPROMER_DIR)/eepromer.o: $(EEPROMER_DIR)/eepromer.c | ||
31 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
32 | |||
33 | $(EEPROMER_DIR)/eeprom.o: $(EEPROMER_DIR)/eeprom.c | ||
34 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
35 | |||
36 | $(EEPROMER_DIR)/eeprog.o: $(EEPROMER_DIR)/eeprog.c | ||
37 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
38 | |||
39 | $(EEPROMER_DIR)/24cXX.o: $(EEPROMER_DIR)/24cXX.c | ||
40 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
41 | |||
42 | # | ||
43 | # Commands | ||
44 | # | ||
45 | |||
46 | all-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
47 | |||
48 | strip-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
49 | strip $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
50 | |||
51 | clean-eepromer: | ||
52 | $(RM) $(addprefix $(EEPROMER_DIR)/,*.o $(EEPROMER_TARGETS)) | ||
53 | |||
54 | install-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
55 | $(INSTALL_DIR) $(DESTDIR)$(sbindir) $(DESTDIR)$(man8dir) | ||
56 | for program in $(EEPROMER_TARGETS) ; do \ | ||
57 | $(INSTALL_PROGRAM) $(EEPROMER_DIR)/$$program $(DESTDIR)$(sbindir) ; done | ||
58 | |||
59 | uninstall-eepromer: | ||
60 | for program in $(EEPROMER_TARGETS) ; do \ | ||
61 | $(RM) $(DESTDIR)$(sbindir)/$$program ; \ | ||
62 | $(RM) $(DESTDIR)$(man8dir)/$$program.8 ; done | ||
63 | |||
64 | all: all-eepromer | ||
65 | |||
66 | strip: strip-eepromer | ||
67 | |||
68 | clean: clean-eepromer | ||
69 | |||
70 | install: install-eepromer | ||
71 | |||
72 | uninstall: uninstall-eepromer | ||
diff --git a/meta-oe/recipes-support/i2c-tools/i2c-tools_3.1.0.bb b/meta-oe/recipes-support/i2c-tools/i2c-tools_3.1.0.bb deleted file mode 100644 index b8be9eddd..000000000 --- a/meta-oe/recipes-support/i2c-tools/i2c-tools_3.1.0.bb +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | SUMMARY = "Set of i2c tools for linux" | ||
2 | SECTION = "base" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
5 | |||
6 | RDEPENDS_${PN} += "perl" | ||
7 | |||
8 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/i2c-tools/i2c-tools-3.1.0.tar.bz2/f15019e559e378c6e9d5d6299a00df21/i2c-tools-${PV}.tar.bz2 \ | ||
9 | file://Module.mk \ | ||
10 | " | ||
11 | SRC_URI[md5sum] = "f15019e559e378c6e9d5d6299a00df21" | ||
12 | SRC_URI[sha256sum] = "960023f61de292c6dd757fcedec4bffa7dd036e8594e24b26a706094ca4c142a" | ||
13 | |||
14 | inherit autotools-brokensep | ||
15 | |||
16 | do_compile_prepend() { | ||
17 | cp ${WORKDIR}/Module.mk ${S}/eepromer/ | ||
18 | sed -i 's#/usr/local#/usr#' ${S}/Makefile | ||
19 | echo "include eepromer/Module.mk" >> ${S}/Makefile | ||
20 | } | ||
21 | |||
22 | do_install_append() { | ||
23 | install -d ${D}${includedir}/linux | ||
24 | install -m 0644 include/linux/i2c-dev.h ${D}${includedir}/linux/i2c-dev-user.h | ||
25 | rm -f ${D}${includedir}/linux/i2c-dev.h | ||
26 | } | ||