diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-05-29 22:40:58 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2011-05-30 11:28:58 +0200 |
commit | 1998f8ef89ed3ff22460465768907ced0c356383 (patch) | |
tree | 42037e76897f7a457c5cf575dd840b4121a348d7 /meta-oe/recipes-support/i2c-tools | |
parent | a6a2f048d18276c1cc042cf0e8f1636f68b26773 (diff) | |
download | meta-openembedded-1998f8ef89ed3ff22460465768907ced0c356383.tar.gz |
i2c-tools: import from OE rev d4f0211e2078d5033ae0dee74664de5520d8392d
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/i2c-tools')
-rw-r--r-- | meta-oe/recipes-support/i2c-tools/i2c-tools-3.0.3/Module.mk | 72 | ||||
-rw-r--r-- | meta-oe/recipes-support/i2c-tools/i2c-tools_3.0.3.bb | 24 |
2 files changed, 96 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/i2c-tools/i2c-tools-3.0.3/Module.mk b/meta-oe/recipes-support/i2c-tools/i2c-tools-3.0.3/Module.mk new file mode 100644 index 000000000..fcaf72f22 --- /dev/null +++ b/meta-oe/recipes-support/i2c-tools/i2c-tools-3.0.3/Module.mk | |||
@@ -0,0 +1,72 @@ | |||
1 | # EEPROMER | ||
2 | # | ||
3 | # Licensed under the GNU General Public License. | ||
4 | |||
5 | EEPROMER_DIR := eepromer | ||
6 | |||
7 | EEPROMER_CFLAGS := -Wstrict-prototypes -Wshadow -Wpointer-arith -Wcast-qual \ | ||
8 | -Wcast-align -Wwrite-strings -Wnested-externs -Winline \ | ||
9 | -W -Wundef -Wmissing-prototypes -Iinclude | ||
10 | |||
11 | EEPROMER_TARGETS := eepromer eeprom eeprog | ||
12 | |||
13 | # | ||
14 | # Programs | ||
15 | # | ||
16 | |||
17 | $(EEPROMER_DIR)/eepromer: $(EEPROMER_DIR)/eepromer.o | ||
18 | $(CC) $(LDFLAGS) -o $@ $^ | ||
19 | |||
20 | $(EEPROMER_DIR)/eeprom: $(EEPROMER_DIR)/eeprom.o | ||
21 | $(CC) $(LDFLAGS) -o $@ $^ | ||
22 | |||
23 | $(EEPROMER_DIR)/eeprog: $(EEPROMER_DIR)/eeprog.o $(EEPROMER_DIR)/24cXX.o | ||
24 | $(CC) $(LDFLAGS) -o $@ $^ | ||
25 | |||
26 | # | ||
27 | # Objects | ||
28 | # | ||
29 | |||
30 | $(EEPROMER_DIR)/eepromer.o: $(EEPROMER_DIR)/eepromer.c | ||
31 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
32 | |||
33 | $(EEPROMER_DIR)/eeprom.o: $(EEPROMER_DIR)/eeprom.c | ||
34 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
35 | |||
36 | $(EEPROMER_DIR)/eeprog.o: $(EEPROMER_DIR)/eeprog.c | ||
37 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
38 | |||
39 | $(EEPROMER_DIR)/24cXX.o: $(EEPROMER_DIR)/24cXX.c | ||
40 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
41 | |||
42 | # | ||
43 | # Commands | ||
44 | # | ||
45 | |||
46 | all-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
47 | |||
48 | strip-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
49 | strip $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
50 | |||
51 | clean-eepromer: | ||
52 | $(RM) $(addprefix $(EEPROMER_DIR)/,*.o $(EEPROMER_TARGETS)) | ||
53 | |||
54 | install-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
55 | $(INSTALL_DIR) $(DESTDIR)$(sbindir) $(DESTDIR)$(man8dir) | ||
56 | for program in $(EEPROMER_TARGETS) ; do \ | ||
57 | $(INSTALL_PROGRAM) $(EEPROMER_DIR)/$$program $(DESTDIR)$(sbindir) ; done | ||
58 | |||
59 | uninstall-eepromer: | ||
60 | for program in $(EEPROMER_TARGETS) ; do \ | ||
61 | $(RM) $(DESTDIR)$(sbindir)/$$program ; \ | ||
62 | $(RM) $(DESTDIR)$(man8dir)/$$program.8 ; done | ||
63 | |||
64 | all: all-eepromer | ||
65 | |||
66 | strip: strip-eepromer | ||
67 | |||
68 | clean: clean-eepromer | ||
69 | |||
70 | install: install-eepromer | ||
71 | |||
72 | uninstall: uninstall-eepromer | ||
diff --git a/meta-oe/recipes-support/i2c-tools/i2c-tools_3.0.3.bb b/meta-oe/recipes-support/i2c-tools/i2c-tools_3.0.3.bb new file mode 100644 index 000000000..021090c37 --- /dev/null +++ b/meta-oe/recipes-support/i2c-tools/i2c-tools_3.0.3.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "Set of i2c tools for linux" | ||
2 | SECTION = "base" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
5 | |||
6 | SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/i2c-tools-${PV}.tar.bz2 \ | ||
7 | file://Module.mk \ | ||
8 | " | ||
9 | SRC_URI[md5sum] = "511376eed04455cdb277ef19c5f73bb4" | ||
10 | SRC_URI[sha256sum] = "23b28e474741834e3f1b35b0686528769a13adc92d2ff5603cbda1d6bd5e5629" | ||
11 | |||
12 | inherit autotools | ||
13 | |||
14 | do_compile_prepend() { | ||
15 | cp ${WORKDIR}/Module.mk ${S}/eepromer/ | ||
16 | sed -i 's#/usr/local#/usr#' Makefile | ||
17 | echo "include eepromer/Module.mk" >> Makefile | ||
18 | } | ||
19 | |||
20 | do_install_append() { | ||
21 | install -d ${D}${includedir}/linux | ||
22 | install -m 0644 include/linux/i2c-dev.h ${D}${includedir}/linux/i2c-dev-user.h | ||
23 | rm -f ${D}${includedir}/linux/i2c-dev.h | ||
24 | } | ||