summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gsoap
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/gsoap
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/gsoap')
-rw-r--r--meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb b/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb
new file mode 100644
index 000000000..b5c399530
--- /dev/null
+++ b/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
2for the development of SOAP Web Services and clients."
3SECTION = "devel"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b338b08b1b61e028e0f399a4de25e58f"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip"
8SRC_URI[md5sum] = "5700d26fc6fe3073d038349e19c3640d"
9SRC_URI[sha256sum] = "51eef118544fa846f4d2dea2eedf91c84c46a1abeafc5eee3dcff783f4015a00"
10
11inherit autotools
12
13BBCLASSEXTEND = "native"
14
15PR = "r1"
16
17S = "${WORKDIR}/${BPN}-2.8"
18
19PARALLEL_MAKE = ""
20
21EXTRA_OEMAKE_class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
22
23DEPENDS_class-target = "gsoap-native openssl zlib"
24DEPENDS_class-native = "flex-native"
25
26do_install_append() {
27 install -d ${D}${libdir}
28 for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
29 do
30 oe_libinstall -C gsoap $lib ${D}${libdir}
31 done
32}
33
34do_install_class-native() {
35 oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install
36}
37
38FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
39FILES_${PN} += "${datadir}"
40FILES_${PN}-staticdev = "${libdir}"
41FILES_${PN}-dev = "${includedir}"
42RRECOMMENDS_${PN}-dev = "${PN}-staticdev"