summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gsoap/gsoap
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-14 22:02:19 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:04:12 +0200
commit767108e49e51246d28676bf4f2a6237edb908a98 (patch)
tree6cfb511cd39d4c6c53b96cb8b3981bd70621d2f3 /meta-oe/recipes-support/gsoap/gsoap
parente64c1a5de1feee59e6ae0c7ed0693f693e8f1b3b (diff)
downloadmeta-openembedded-767108e49e51246d28676bf4f2a6237edb908a98.tar.gz
gsoap: Upgrade to 2.8.51
Fixes build with openssl 1.1 Add patch to fix out of tree build License changes are due to restructing of license files see https://sourceforge.net/p/gsoap2/code/123/ Add OpenSSL exception to LICENSE field which was missing thus far. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gsoap/gsoap')
-rw-r--r--meta-oe/recipes-support/gsoap/gsoap/0001-Fix-out-of-tree-builds.patch178
1 files changed, 178 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gsoap/gsoap/0001-Fix-out-of-tree-builds.patch b/meta-oe/recipes-support/gsoap/gsoap/0001-Fix-out-of-tree-builds.patch
new file mode 100644
index 000000000..5ceb4bf02
--- /dev/null
+++ b/meta-oe/recipes-support/gsoap/gsoap/0001-Fix-out-of-tree-builds.patch
@@ -0,0 +1,178 @@
1From 8a10b6bd556426616e93f15639f369defbeca33f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 14 Aug 2017 11:58:58 -0700
4Subject: [PATCH] Fix out of tree builds
5
6When build dir is not same as sourcedir then the build failed due
7to use of $(srcdir) variable which assumes source = build therefore
8replace that with top_srcdir
9
10Additionally move the conditional addition of sources to Makefile.am
11instead of adding it in configure.ac, since then we can use top_srcdir
12variable to access those sources too otherwise its not possible to
13specify the right dir for these sources
14
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17Upstream-Status: Submitted[https://sourceforge.net/p/gsoap2/patches/171/]
18
19 configure.ac | 5 +++--
20 gsoap/Makefile.am | 14 +++++++-------
21 gsoap/samples/autotest/Makefile.am | 8 ++++----
22 gsoap/samples/databinding/Makefile.am | 8 ++++----
23 gsoap/wsdl/Makefile.am | 15 +++++++++------
24 5 files changed, 27 insertions(+), 23 deletions(-)
25
26diff --git a/configure.ac b/configure.ac
27index 0631c18..c36e696 100644
28--- a/configure.ac
29+++ b/configure.ac
30@@ -265,7 +265,7 @@ if test "x$with_openssl" = "xyes"; then
31 WSDL2H_EXTRA_FLAGS="-DWITH_OPENSSL -DWITH_GZIP"
32 # an ugly hack to get httpda and smdevp plugins to conditionally
33 # compile with wsdl2h when OPENSSL is available
34- WSDL2H_EXTRA_LIBS="${WSDL2H_EXTRA_LIBS} ../plugin/httpda.c ../plugin/smdevp.c ../plugin/threads.c -lssl -lcrypto -lz"
35+ WSDL2H_EXTRA_LIBS="${WSDL2H_EXTRA_LIBS} -lssl -lcrypto -lz"
36 SAMPLE_INCLUDES=
37 SAMPLE_SSL_LIBS="-lssl -lcrypto -lz"
38 WSDL2H_SOAP_CPP_LIB="libgsoapssl++.a"
39@@ -289,12 +289,13 @@ else
40 SAMPLE_INCLUDES=
41 WSDL2H_SOAP_CPP_LIB="libgsoap++.a"
42 fi
43+AM_CONDITIONAL(WITH_OPENSSL, test "x$with_openssl" = "xyes" -a "x$with_gnutls" != "xyes")
44+AC_SUBST(WITH_OPENSSL)
45 AC_SUBST(WSDL2H_EXTRA_FLAGS)
46 AC_SUBST(WSDL2H_EXTRA_LIBS)
47 AC_SUBST(SAMPLE_INCLUDES)
48 AC_SUBST(SAMPLE_SSL_LIBS)
49 AC_SUBST(WSDL2H_SOAP_CPP_LIB)
50-
51 # enable the compile of the samples
52 AC_ARG_ENABLE(samples,
53 [ --enable-samples enable compile for the gsoap samples],
54diff --git a/gsoap/Makefile.am b/gsoap/Makefile.am
55index 7273b82..9c0c89f 100644
56--- a/gsoap/Makefile.am
57+++ b/gsoap/Makefile.am
58@@ -13,26 +13,26 @@ AM_CXXFLAGS = $(SOAPCPP2_DEBUG) -D$(platform)
59 AM_CFLAGS = $(SOAPCPP2_DEBUG) -D$(platform)
60
61 # Install all soapcpp2 and wsdl2h files into ${prefix}/share/gsoap
62-nobase_pkgdata_DATA = $(srcdir)/import/* $(srcdir)/plugin/* $(srcdir)/WS/* $(srcdir)/custom/* $(srcdir)/extras/*
63+nobase_pkgdata_DATA = $(top_srcdir)/gsoap/import/* $(top_srcdir)/gsoap/plugin/* $(top_srcdir)/gsoap/WS/* $(top_srcdir)/gsoap/custom/* $(top_srcdir)/gsoap/extras/*
64
65 ## we cannot build stdsoap2.o from 2 different sources (stdsoap2.cpp and stdsoap2.c), so we need an intermediate target:
66 stdsoap2_ck.c: stdsoap2.cpp
67- $(LN_S) -f $(srcdir)/stdsoap2.cpp stdsoap2_ck.c
68+ $(LN_S) -f $(top_srcdir)/gsoap/stdsoap2.cpp stdsoap2_ck.c
69
70 stdsoap2_cpp.cpp: stdsoap2.cpp
71- $(LN_S) -f $(srcdir)/stdsoap2.cpp stdsoap2_cpp.cpp
72+ $(LN_S) -f $(top_srcdir)/gsoap/stdsoap2.cpp stdsoap2_cpp.cpp
73
74 stdsoap2_ck_cpp.cpp: stdsoap2.cpp
75- $(LN_S) -f $(srcdir)/stdsoap2.cpp stdsoap2_ck_cpp.cpp
76+ $(LN_S) -f $(top_srcdir)/gsoap/stdsoap2.cpp stdsoap2_ck_cpp.cpp
77
78 stdsoap2_ssl.c: stdsoap2.cpp
79- $(LN_S) -f $(srcdir)/stdsoap2.cpp stdsoap2_ssl.c
80+ $(LN_S) -f $(top_srcdir)/gsoap/stdsoap2.cpp stdsoap2_ssl.c
81
82 stdsoap2_ssl_cpp.cpp: stdsoap2.cpp
83- $(LN_S) -f $(srcdir)/stdsoap2.cpp stdsoap2_ssl_cpp.cpp
84+ $(LN_S) -f $(top_srcdir)/gsoap/stdsoap2.cpp stdsoap2_ssl_cpp.cpp
85 ## do the same fo dom.cpp since we want to link it into the cpp libs and dom.c into the c libs
86 dom_cpp.cpp: dom.cpp
87- $(LN_S) -f $(srcdir)/dom.cpp dom_cpp.cpp
88+ $(LN_S) -f $(top_srcdir)/gsoap/dom.cpp dom_cpp.cpp
89
90 lib_LIBRARIES = libgsoap.a libgsoap++.a libgsoapck.a libgsoapck++.a libgsoapssl.a libgsoapssl++.a
91
92diff --git a/gsoap/samples/autotest/Makefile.am b/gsoap/samples/autotest/Makefile.am
93index 36adf51..61e514c 100644
94--- a/gsoap/samples/autotest/Makefile.am
95+++ b/gsoap/samples/autotest/Makefile.am
96@@ -6,13 +6,13 @@
97 AUTOMAKE_OPTIONS = subdir-objects foreign 1.4
98
99 CPPFLAGS=-I$(top_srcdir)/gsoap -I$(top_srcdir)/gsoap/plugin
100-AM_LDFLAGS=$(CPPFLAGS) -I$(srcdir) -L$(srcdir)
101+AM_LDFLAGS=$(CPPFLAGS) -I$(top_srcdir)/gsoap/samples/autotest -L$(top_srcdir)/gsoap/samples/autotest
102 SOAP=$(top_srcdir)/gsoap/src/soapcpp2$(EXEEXT)
103 WSDL=$(top_srcdir)/gsoap/wsdl/wsdl2h$(EXEEXT)
104-WSDL_FLAGS=-d -P -t $(srcdir)/typemap.dat
105+WSDL_FLAGS=-d -P -t $(top_srcdir)/gsoap/samples/autotest/typemap.dat
106 SOAP_FLAGS=-SL -T -I$(top_srcdir)/gsoap/import -I$(top_srcdir)/gsoap/custom
107-WSDLINPUT=$(srcdir)/examples.wsdl
108-SOAPHEADER=$(srcdir)/examples.h
109+WSDLINPUT=$(top_srcdir)/gsoap/samples/autotest/examples.wsdl
110+SOAPHEADER=$(top_srcdir)/gsoap/samples/autotest/examples.h
111 SOAP_CPP_SRC=soapC.cpp soapServer.cpp
112 SOAP_CPP_LIB=$(top_builddir)/gsoap/libgsoap++.a
113
114diff --git a/gsoap/samples/databinding/Makefile.am b/gsoap/samples/databinding/Makefile.am
115index 892d4fd..86ad482 100644
116--- a/gsoap/samples/databinding/Makefile.am
117+++ b/gsoap/samples/databinding/Makefile.am
118@@ -6,13 +6,13 @@
119 AUTOMAKE_OPTIONS = subdir-objects foreign 1.4
120
121 CPPFLAGS=$(SAMPLE_INCLUDES) -I$(top_srcdir)/gsoap -I$(top_srcdir)/gsoap/plugin
122-AM_LDFLAGS=$(AM_CPPFLAGS) -I$(srcdir) -L$(srcdir)
123+AM_LDFLAGS=$(AM_CPPFLAGS) -I$(top_srcdir)/gsoap/samples/databinding -L$(top_srcdir)/gsoap/samples/databinding
124 SOAP=$(top_srcdir)/gsoap/src/soapcpp2$(EXEEXT)
125 WSDL=$(top_srcdir)/gsoap/wsdl/wsdl2h$(EXEEXT)
126-WSDL_FLAGS=-g -t $(srcdir)/addresstypemap.dat
127+WSDL_FLAGS=-g -t $(top_srcdir)/gsoap/samples/databinding/addresstypemap.dat
128 SOAP_FLAGS=-0 -CS -p address -I$(top_srcdir)/gsoap/import
129-WSDLINPUT=$(srcdir)/address.xsd
130-SOAPHEADER=$(srcdir)/address.h
131+WSDLINPUT=$(top_srcdir)/gsoap/samples/databinding/address.xsd
132+SOAPHEADER=$(top_srcdir)/gsoap/samples/databinding/address.h
133 SOAP_CPP_SRC=addressC.cpp
134 SOAP_CPP_LIB=$(top_builddir)/gsoap/libgsoap++.a
135
136diff --git a/gsoap/wsdl/Makefile.am b/gsoap/wsdl/Makefile.am
137index b8da5db..9f2aefa 100644
138--- a/gsoap/wsdl/Makefile.am
139+++ b/gsoap/wsdl/Makefile.am
140@@ -6,14 +6,14 @@
141 AUTOMAKE_OPTIONS = foreign 1.4
142
143 # INCLUDES=-I$(top_srcdir)/gsoap
144-# AM_LDFLAGS=$(INCLUDES) -I$(srcdir) -L$(srcdir)
145-AM_LDFLAGS=-L$(srcdir) -I$(top_srcdir)/gsoap -I$(top_srcdir)/gsoap/plugin
146+# AM_LDFLAGS=$(INCLUDES) -I$(top_srcdir)/gsoap/wsdl -L$(top_srcdir)/gsoap/wsdl
147+AM_LDFLAGS=-L$(top_srcdir)/gsoap/wsdl -I$(top_srcdir)/gsoap -I$(top_srcdir)/gsoap/plugin
148 AM_CPPFLAGS=-I$(top_srcdir)/gsoap -I$(top_srcdir)/gsoap/plugin
149 SOAP=$(top_builddir)/gsoap/src/soapcpp2$(EXEEXT)
150 SOAP_CPP_LIB=$(top_builddir)/gsoap/$(WSDL2H_SOAP_CPP_LIB)
151 SOAP_CPP_SRC=wsdlC.cpp
152-SOAPHEADER=$(srcdir)/wsdl.h
153-SOAP_FLAGS=-SC -pwsdl -I$(srcdir) -I$(top_srcdir)/gsoap/import
154+SOAPHEADER=$(top_srcdir)/gsoap/wsdl/wsdl.h
155+SOAP_FLAGS=-SC -pwsdl -I$(top_srcdir)/gsoap/wsdl -I$(top_srcdir)/gsoap/import
156 BUILT_SOURCES=$(SOAP_CPP_SRC)
157 # WSDL2H_EXTRA_FLAGS=-DWITH_OPENSSL -DWITH_GZIP # defined in configure.in
158 # WSDL2H_EXTRA_LIBS=-lssl -lcrypto -lz # defined in configure.in
159@@ -24,11 +24,14 @@ $(SOAP_CPP_SRC) : $(SOAPHEADER)
160 #LIBS=
161
162 bin_PROGRAMS=wsdl2h
163-
164+if WITH_OPENSSL
165+wsdl2h_LDADD=$(SOAP_CPP_LIB) $(top_srcdir)/gsoap/plugin/httpda.c $(top_srcdir)/gsoap/plugin/smdevp.c $(top_srcdir)/gsoap/plugin/threads.c $(WSDL2H_EXTRA_LIBS)
166+else
167+wsdl2h_LDADD=$(SOAP_CPP_LIB) $(WSDL2H_EXTRA_LIBS)
168+endif
169 wsdl2h_CFLAGS=$(C_DEBUG_FLAGS) $(SOAPCPP2_NO_C_LOCALE) $(WSDL2H_EXTRA_FLAGS)
170 wsdl2h_CXXFLAGS=$(C_DEBUG_FLAGS) $(SOAPCPP2_NO_C_LOCALE) $(WSDL2H_EXTRA_FLAGS) $(WSDL2H_IMPORTPATH)
171 wsdl2h_CPPFLAGS=$(AM_CPPFLAGS) $(SOAPCPP2_NONAMESPACES) -D$(platform)
172 wsdl2h_SOURCES=wsdl2h.cpp wsdl.cpp wadl.cpp schema.cpp types.cpp service.cpp soap.cpp mime.cpp wsp.cpp bpel.cpp $(SOAP_CPP_SRC)
173-wsdl2h_LDADD=$(SOAP_CPP_LIB) $(WSDL2H_EXTRA_LIBS)
174
175 CLEANFILES= *~ *C.cpp *H.h *Stub.h *.nsmap
176--
1772.14.1
178