summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gpm
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/gpm
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/gpm')
-rw-r--r--meta-oe/recipes-support/gpm/gpm-1.99.7/eglibc-2.17.patch12
-rw-r--r--meta-oe/recipes-support/gpm/gpm-1.99.7/init32
-rw-r--r--meta-oe/recipes-support/gpm/gpm-1.99.7/no-docs.patch18
-rw-r--r--meta-oe/recipes-support/gpm/gpm-1.99.7/processcreds.patch12
-rw-r--r--meta-oe/recipes-support/gpm/gpm_1.99.7.bb52
5 files changed, 126 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gpm/gpm-1.99.7/eglibc-2.17.patch b/meta-oe/recipes-support/gpm/gpm-1.99.7/eglibc-2.17.patch
new file mode 100644
index 000000000..e43bdcb22
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm-1.99.7/eglibc-2.17.patch
@@ -0,0 +1,12 @@
1Upstream-Status: pending
2
3--- gpm-1.99.7.orig/src/daemon/open_console.c 2008-07-24 12:33:05.000000000 +0200
4+++ gpm-1.99.7/src/daemon/open_console.c 2013-01-10 12:39:47.975461947 +0100
5@@ -23,6 +23,7 @@
6 #include <fcntl.h> /* open and co. */
7 #include <sys/stat.h> /* stat() */
8 #include <sys/ioctl.h> /* ioctl() */
9+#include <sys/types.h> /* major() */
10
11 /* Linux specific (to be outsourced in gpm2 */
12 #include <linux/serial.h> /* for serial console check */
diff --git a/meta-oe/recipes-support/gpm/gpm-1.99.7/init b/meta-oe/recipes-support/gpm/gpm-1.99.7/init
new file mode 100644
index 000000000..2dcf9ab04
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm-1.99.7/init
@@ -0,0 +1,32 @@
1#! /bin/sh
2
3# Grab the common functions
4#. /etc/init.d/functions
5
6# FIXME:
7# Add a configuration file for GPM here
8
9test -x /usr/sbin/gpm || exit 0
10
11case "$1" in
12 start)
13 if [ ! -p /dev/gpmdata ]; then
14 mkfifo /dev/gpmdata
15 fi
16
17 echo "Starting GPM:"
18 start-stop-daemon -S -x /usr/sbin/gpm -- -R -m /dev/psaux -t ps2
19 ;;
20 stop)
21 echo "Stopping GPM:"
22 start-stop-daemon -K -x /usr/sbin/gpm
23 ;;
24 restart|force-reload)
25 $0 stop
26 $0 start
27 ;;
28 *)
29 usage /etc/init.d/gpm
30esac
31
32exit 0
diff --git a/meta-oe/recipes-support/gpm/gpm-1.99.7/no-docs.patch b/meta-oe/recipes-support/gpm/gpm-1.99.7/no-docs.patch
new file mode 100644
index 000000000..f10217a94
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm-1.99.7/no-docs.patch
@@ -0,0 +1,18 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6Index: gpm-1.99.7/Makefile.in
7===================================================================
8--- gpm-1.99.7.orig/Makefile.in 2008-07-24 03:36:35.000000000 -0700
9+++ gpm-1.99.7/Makefile.in 2010-06-22 18:28:45.269507001 -0700
10@@ -19,7 +19,7 @@
11 # user-overridable flags, but it's also all the implicit rule looks at.
12 # missing ?
13
14-SUBDIRS = src doc contrib gpm2
15+SUBDIRS = src
16
17
18 ### simple, but effective rules
diff --git a/meta-oe/recipes-support/gpm/gpm-1.99.7/processcreds.patch b/meta-oe/recipes-support/gpm/gpm-1.99.7/processcreds.patch
new file mode 100644
index 000000000..d647eca0a
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm-1.99.7/processcreds.patch
@@ -0,0 +1,12 @@
1Index: gpm-1.99.7/src/daemon/processconn.c
2===================================================================
3--- gpm-1.99.7.orig/src/daemon/processconn.c 2010-09-29 17:36:18.571782951 +0400
4+++ gpm-1.99.7/src/daemon/processconn.c 2010-09-29 17:42:44.659991758 +0400
5@@ -20,6 +20,7 @@
6 *
7 ********/
8
9+#define _GNU_SOURCE
10 #include <sys/socket.h> /* accept */
11 #include <stdlib.h> /* malloc */
12 #include <unistd.h> /* close */
diff --git a/meta-oe/recipes-support/gpm/gpm_1.99.7.bb b/meta-oe/recipes-support/gpm/gpm_1.99.7.bb
new file mode 100644
index 000000000..7022057d4
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm_1.99.7.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
2for the console and xterm, with sample clients included \
3(emacs, etc)."
4SECTION = "console/utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://gpm2/core/main.c;endline=19;md5=66d3c205c4e7ee5704b2ee351dfed72f"
7
8PR = "r2"
9
10DEPENDS = "ncurses"
11
12SRC_URI = "ftp://arcana.linux.it/pub/gpm/gpm-${PV}.tar.bz2 \
13 file://no-docs.patch \
14 file://processcreds.patch \
15 file://eglibc-2.17.patch \
16 file://init"
17
18inherit autotools-brokensep update-rc.d
19
20INITSCRIPT_NAME = "gpm"
21INITSCRIPT_PARAMS = "defaults"
22
23#export LIBS = "-lm"
24
25# all fields are /* FIXME: gpm 1.99.13 */
26# gpm-1.99.7/src/lib/libhigh.c:171:43: error: parameter 'clientdata' set but not used [-Werror=unused-but-set-parameter]
27# gpm-1.99.7/src/lib/report-lib.c:28:21: error: parameter 'line' set but not used [-Werror=unused-but-set-parameter]
28# gpm-1.99.7/src/lib/report-lib.c:28:33: error: parameter 'file' set but not used [-Werror=unused-but-set-parameter]
29# gpm-1.99.7/src/drivers/empty/i.c:26:23: error: parameter 'fd' set but not used [-Werror=unused-but-set-parameter]
30# gpm-1.99.7/src/drivers/empty/i.c:26:42: error: parameter 'flags' set but not used [-Werror=unused-but-set-parameter]
31# gpm-1.99.7/src/drivers/etouch/i.c:34:43: error: parameter 'flags' set but not used [-Werror=unused-but-set-parameter]
32# gpm-1.99.7/src/drivers/msc/r.c:32:12: error: variable 'dy' set but not used [-Werror=unused-but-set-variable]
33# gpm-1.99.7/src/drivers/msc/r.c:32:8: error: variable 'dx' set but not used [-Werror=unused-but-set-variable]
34# cc1: all warnings being treated as errors
35CFLAGS += "-Wno-extra -Wno-error=unused-but-set-parameter -Wno-error=unused-but-set-variable"
36
37# twiddler is WIP in 1.99.7 and probably not worth fixing (a lot of changes in gpm-2-dev after 1.99.7
38# gpm-1.99.7/src/drivers/twid/twiddler.c:503:14: error: cast to pointer from integer of different size [-Werror=int-to-pointer-cast]
39# /gpm-1.99.7/src/mice.c:221:5: error: (near initialization for 'mice[32].init') [-Werror]
40CFLAGS += "-Wno-error=int-to-pointer-cast -Wno-error"
41
42do_install () {
43 oe_runmake 'DESTDIR=${D}' install
44 install -m 0644 src/headers/gpm.h ${D}${includedir}
45 install -d ${D}/${sysconfdir}/init.d
46 install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/gpm
47 cd ${D}${libdir} && ln -sf libgpm.so.1.19.0 libgpm.so.1
48}
49SRC_URI[md5sum] = "9fdddf5f53cb11d40bb2bb671d3ac544"
50SRC_URI[sha256sum] = "6071378b24494e36ca3ef6377606e7e565040413c86704753a162d2180af32ee"
51
52FILES_${PN} += "${datadir}/emacs"