diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-07-01 13:30:32 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-14 23:44:30 +0200 |
commit | 23a1d7accaf7c71559944a83cdb8622eb2be6d05 (patch) | |
tree | 380265cef487e70d542ea4d400efe48dc7ed3930 /meta-oe/recipes-support/gperftools | |
parent | 8c89764648787e6df51a89d708492b137ec40cd5 (diff) | |
download | meta-openembedded-23a1d7accaf7c71559944a83cdb8622eb2be6d05.tar.gz |
gperftools: Fix build on ppc
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gperftools')
-rw-r--r-- | meta-oe/recipes-support/gperftools/gperftools/0001-Use-ucontext_t-instead-of-struct-ucontext.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-support/gperftools/gperftools_2.5.bb | 3 |
2 files changed, 38 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/gperftools/gperftools/0001-Use-ucontext_t-instead-of-struct-ucontext.patch b/meta-oe/recipes-support/gperftools/gperftools/0001-Use-ucontext_t-instead-of-struct-ucontext.patch new file mode 100644 index 000000000..5bd0b6fa4 --- /dev/null +++ b/meta-oe/recipes-support/gperftools/gperftools/0001-Use-ucontext_t-instead-of-struct-ucontext.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 12ac0dc6742e1bcdfaf1842186c9002f0820a5e8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 1 Jul 2017 13:21:21 -0700 | ||
4 | Subject: [PATCH] Use ucontext_t instead of struct ucontext | ||
5 | |||
6 | Newer glibc has dropped the ucontext tag from exposing | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | src/stacktrace_powerpc-linux-inl.h | 3 +-- | ||
11 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/src/stacktrace_powerpc-linux-inl.h b/src/stacktrace_powerpc-linux-inl.h | ||
14 | index a9bf775..47ff2d7 100644 | ||
15 | --- a/src/stacktrace_powerpc-linux-inl.h | ||
16 | +++ b/src/stacktrace_powerpc-linux-inl.h | ||
17 | @@ -53,7 +53,6 @@ | ||
18 | #elif defined(HAVE_UCONTEXT_H) | ||
19 | #include <ucontext.h> // for ucontext_t | ||
20 | #endif | ||
21 | -typedef ucontext ucontext_t; | ||
22 | |||
23 | // PowerPC64 Little Endian follows BE wrt. backchain, condition register, | ||
24 | // and LR save area, so no need to adjust the reading struct. | ||
25 | @@ -202,7 +201,7 @@ static int GET_STACK_TRACE_OR_FRAMES { | ||
26 | struct rt_signal_frame_32 { | ||
27 | char dummy[64 + 16]; | ||
28 | siginfo_t info; | ||
29 | - struct ucontext uc; | ||
30 | + ucontext_t uc; | ||
31 | // We don't care about the rest, since IP value is at 'uc' field.A | ||
32 | } *sigframe = reinterpret_cast<rt_signal_frame_32*>(current); | ||
33 | result[n] = (void*) sigframe->uc.uc_mcontext.uc_regs->gregs[PT_NIP]; | ||
34 | -- | ||
35 | 2.13.2 | ||
36 | |||
diff --git a/meta-oe/recipes-support/gperftools/gperftools_2.5.bb b/meta-oe/recipes-support/gperftools/gperftools_2.5.bb index 15cfc97e8..43780a5ee 100644 --- a/meta-oe/recipes-support/gperftools/gperftools_2.5.bb +++ b/meta-oe/recipes-support/gperftools/gperftools_2.5.bb | |||
@@ -7,7 +7,8 @@ DEPENDS = "libunwind" | |||
7 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/gperftools/gperftools-2.5.tar.gz/aa1eaf95dbe2c9828d0bd3a00f770f50/gperftools-2.5.tar.gz \ | 7 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/gperftools/gperftools-2.5.tar.gz/aa1eaf95dbe2c9828d0bd3a00f770f50/gperftools-2.5.tar.gz \ |
8 | file://0001-Support-Atomic-ops-on-clang.patch \ | 8 | file://0001-Support-Atomic-ops-on-clang.patch \ |
9 | file://0001-Fix-build-failure-for-ppc.patch \ | 9 | file://0001-Fix-build-failure-for-ppc.patch \ |
10 | " | 10 | file://0001-Use-ucontext_t-instead-of-struct-ucontext.patch \ |
11 | " | ||
11 | 12 | ||
12 | SRC_URI[md5sum] = "aa1eaf95dbe2c9828d0bd3a00f770f50" | 13 | SRC_URI[md5sum] = "aa1eaf95dbe2c9828d0bd3a00f770f50" |
13 | SRC_URI[sha256sum] = "6fa2748f1acdf44d750253e160cf6e2e72571329b42e563b455bde09e9e85173" | 14 | SRC_URI[sha256sum] = "6fa2748f1acdf44d750253e160cf6e2e72571329b42e563b455bde09e9e85173" |