summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-12 11:30:38 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:22 +0200
commitd1ebcbc62983d5547c31199751e8e015d9b018f0 (patch)
treea1e05266d2d3e63cf07d6b08e32e49984a2895c9 /meta-oe/recipes-support/gd
parentbb689de1d32d2561fe365e0b59f355b746cfd0ac (diff)
downloadmeta-openembedded-d1ebcbc62983d5547c31199751e8e015d9b018f0.tar.gz
gd: update to version 2.2.3
* Upstream removed vpx support in favor of webp * Explicity disable webp support Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gd')
-rw-r--r--meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch43
-rw-r--r--meta-oe/recipes-support/gd/gd_2.2.3.bb (renamed from meta-oe/recipes-support/gd/gd_2.1.1.bb)12
2 files changed, 49 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch b/meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch
new file mode 100644
index 000000000..02cb5ad75
--- /dev/null
+++ b/meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch
@@ -0,0 +1,43 @@
1gdft.c: remove functions that cause warnings about being unused
2
3Upstream-Status: Backport (Fixed in master branch)
4
5Signed-off-by: Derek Straka <derek@asterius.io>
6--- git/src/gdft.c.orig 2016-08-12 10:20:41.418440091 -0400
7+++ git/src/gdft.c 2016-08-12 10:22:34.226442987 -0400
8@@ -139,16 +139,6 @@
9 }
10 #else
11
12-#ifndef HAVE_LIBFONTCONFIG
13-static char * font_pattern(char **fontpath, char *fontpattern)
14-{
15- (void)fontpath;
16- (void)fontpattern;
17-
18- return "libgd was not built with FontConfig support\n";
19-}
20-#endif /* HAVE_LIBFONTCONFIG */
21-
22 #include "gdcache.h"
23 /* 2.0.16 Christophe Thomas: starting with FreeType 2.1.6, this is
24 mandatory, and it has been supported for a long while. */
25@@ -446,16 +436,15 @@
26 return (strcmp (a->fontlist, b->fontlist) == 0 && a->flags == b->flags);
27 }
28
29+#ifdef HAVE_LIBFONTCONFIG
30 static int useFontConfig(int flag)
31 {
32-#ifdef HAVE_LIBFONTCONFIG
33 if (fontConfigFlag) {
34 return (!(flag & gdFTEX_FONTPATHNAME));
35 }
36-#endif
37 return flag & gdFTEX_FONTCONFIG;
38 }
39-
40+#endif
41 static void *
42 fontFetch (char **error, void *key)
43 {
diff --git a/meta-oe/recipes-support/gd/gd_2.1.1.bb b/meta-oe/recipes-support/gd/gd_2.2.3.bb
index 85c7e6a05..80d66c9f7 100644
--- a/meta-oe/recipes-support/gd/gd_2.1.1.bb
+++ b/meta-oe/recipes-support/gd/gd_2.2.3.bb
@@ -12,12 +12,12 @@ LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669" 12LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
13DEPENDS = "freetype libpng jpeg zlib tiff" 13DEPENDS = "freetype libpng jpeg zlib tiff"
14 14
15SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2 \ 15SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \
16" 16 file://fix-gcc-unused-functions.patch"
17SRC_URI[md5sum] = "d3f1a992ac9c550ebc6da89c147f89af"
18SRC_URI[sha256sum] = "895ea9c6fcab187b0a908ae3e9e6b06423756f8a643d362349b0caab4014bd0d"
19 17
20S = "${WORKDIR}/libgd-${PV}" 18SRCREV = "46ceef5970bf3a847ff61d1bdde7501d66c11d0c"
19
20S = "${WORKDIR}/git"
21 21
22inherit autotools binconfig gettext pkgconfig 22inherit autotools binconfig gettext pkgconfig
23 23
@@ -25,9 +25,9 @@ EXTRA_OECONF += " --disable-rpath \
25 --with-jpeg=${STAGING_LIBDIR}/.. \ 25 --with-jpeg=${STAGING_LIBDIR}/.. \
26 --with-freetype=yes \ 26 --with-freetype=yes \
27 --without-fontconfig \ 27 --without-fontconfig \
28 --without-webp \
28 --without-xpm \ 29 --without-xpm \
29 --without-x \ 30 --without-x \
30 --without-vpx \
31 " 31 "
32 32
33EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"' 33EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'