summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/gd
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/gd')
-rw-r--r--meta-oe/recipes-support/gd/gd-2.1.0/fix-the-subdir-objects-error.patch39
-rw-r--r--meta-oe/recipes-support/gd/gd_2.1.0.bb41
2 files changed, 80 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd-2.1.0/fix-the-subdir-objects-error.patch b/meta-oe/recipes-support/gd/gd-2.1.0/fix-the-subdir-objects-error.patch
new file mode 100644
index 000000000..02b167067
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd-2.1.0/fix-the-subdir-objects-error.patch
@@ -0,0 +1,39 @@
1From b1ae702a48888e2c3b0ebe0772a88b45a37b84f5 Mon Sep 17 00:00:00 2001
2From: Robert Yang <liezhi.yang@windriver.com>
3Date: Fri, 17 Jan 2014 01:58:05 -0500
4Subject: [PATCH] configure.ac: fix the subdir-objects error
5
6Fix this error:
7iautomake: warning: possible forward-incompatibility.
8automake: At least a source file is in a subdirectory, but the 'subdir-objects'
9automake: automake option hasn't been enabled. For now, the corresponding output
10automake: object file(s) will be placed in the top-level directory. However,
11automake: this behaviour will change in future Automake versions: they will
12automake: unconditionally cause object files to be placed in the same subdirectory
13automake: of the corresponding sources.
14automake: You are advised to start using 'subdir-objects' option throughout your
15automake: project, to avoid future incompatibilities.
16
17Upstream-Status: Pending
18
19Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
20---
21 configure.ac | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/configure.ac b/configure.ac
25index 2f9f744..438e08b 100644
26--- a/configure.ac
27+++ b/configure.ac
28@@ -45,7 +45,7 @@ AC_SUBST(GDLIB_AGE)
29 FEATURES="GD_GIF GD_GIFANIM GD_OPENPOLYGON"
30 AC_SUBST(FEATURES)
31
32-AM_INIT_AUTOMAKE([foreign dist-bzip2 dist-xz -Wall -Werror])
33+AM_INIT_AUTOMAKE([foreign dist-bzip2 dist-xz -Wall -Werror subdir-objects])
34 AC_CONFIG_HEADERS([src/config.h:src/config.hin])
35
36 dnl newer automake wants this, but we still want to work with older
37--
381.7.10.4
39
diff --git a/meta-oe/recipes-support/gd/gd_2.1.0.bb b/meta-oe/recipes-support/gd/gd_2.1.0.bb
new file mode 100644
index 000000000..f03b9b08b
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.1.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.bitbucket.org/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
13DEPENDS = "freetype libpng jpeg zlib tiff libvpx"
14
15SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2 \
16 file://fix-the-subdir-objects-error.patch \
17"
18SRC_URI[md5sum] = "5a1d5bab3a4a41d9f111bcceee4ad25b"
19SRC_URI[sha256sum] = "f3e1bc472bd81ee976a739436659fe752a14727a964c64530fde68531ddeee91"
20
21S = "${WORKDIR}/libgd-${PV}"
22
23inherit autotools binconfig gettext pkgconfig
24
25EXTRA_OECONF += " --disable-rpath \
26 --with-jpeg=${STAGING_LIBDIR}/.. \
27 --with-freetype=yes \
28 --without-fontconfig \
29 --without-xpm \
30 --without-x"
31
32EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
33
34PACKAGES += "${PN}-tools"
35
36FILES_${PN} = "${libdir}/lib*${SOLIBS}"
37FILES_${PN}-tools = "${bindir}/*"
38
39PROVIDES += "${PN}-tools"
40RPROVIDES_${PN}-tools = "${PN}-tools"
41RDEPENDS_${PN}-tools = "perl perl-module-strict"