summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd/gd_2.3.0.bb
diff options
context:
space:
mode:
authorSakib Sajal <sakib.sajal@windriver.com>2020-03-26 13:15:45 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-26 20:35:47 -0700
commit39e3a1936ebf94388e08d32d8563efc543bad053 (patch)
treecb0627d56da4abf12872e413b8664e4c905402ab /meta-oe/recipes-support/gd/gd_2.3.0.bb
parente59d4df02f980e0dc57d45104320f5b3286025a0 (diff)
downloadmeta-openembedded-39e3a1936ebf94388e08d32d8563efc543bad053.tar.gz
gd: uprev from 2.2.5 to 2.3.0
Major release after 2.2.5. Changelog: https://github.com/libgd/libgd/blob/gd-2.3.0/CHANGELOG.md Changes: - SRC_REV points to tag gd-2.3.0 - branch in SRC_URI points to master - updated homepage - removed patches as they were merged upstream under gd-2.3.0 tag Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gd/gd_2.3.0.bb')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.3.0.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.3.0.bb b/meta-oe/recipes-support/gd/gd_2.3.0.bb
new file mode 100644
index 000000000..eec8a05ae
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.3.0.bb
@@ -0,0 +1,52 @@
1SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.github.io/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=8e5bc8627b9494741c905d65238c66b7"
13
14DEPENDS = "freetype libpng jpeg zlib tiff"
15
16SRC_URI = "git://github.com/libgd/libgd.git;branch=master \
17 "
18
19SRCREV = "b079fa06223c3ab862c8f0eea58a968727971988"
20
21S = "${WORKDIR}/git"
22
23inherit autotools binconfig gettext pkgconfig
24
25EXTRA_OECONF += " --disable-rpath \
26 --with-jpeg=${STAGING_LIBDIR}/.. \
27 --with-freetype=yes \
28 --without-fontconfig \
29 --without-webp \
30 --without-xpm \
31 --without-x \
32 "
33
34EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
35
36DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized"
37
38do_install_append() {
39 # cleanup buildpaths from gdlib.pc
40 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
41}
42
43PACKAGES += "${PN}-tools"
44
45FILES_${PN} = "${libdir}/lib*${SOLIBS}"
46FILES_${PN}-tools = "${bindir}/*"
47
48PROVIDES += "${PN}-tools"
49RPROVIDES_${PN}-tools = "${PN}-tools"
50RDEPENDS_${PN}-tools = "perl perl-module-strict"
51
52CVE_PRODUCT = "libgd"