summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd/gd_2.2.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-12 11:30:38 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:22 +0200
commitd1ebcbc62983d5547c31199751e8e015d9b018f0 (patch)
treea1e05266d2d3e63cf07d6b08e32e49984a2895c9 /meta-oe/recipes-support/gd/gd_2.2.3.bb
parentbb689de1d32d2561fe365e0b59f355b746cfd0ac (diff)
downloadmeta-openembedded-d1ebcbc62983d5547c31199751e8e015d9b018f0.tar.gz
gd: update to version 2.2.3
* Upstream removed vpx support in favor of webp * Explicity disable webp support Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gd/gd_2.2.3.bb')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.2.3.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.2.3.bb b/meta-oe/recipes-support/gd/gd_2.2.3.bb
new file mode 100644
index 000000000..80d66c9f7
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.2.3.bb
@@ -0,0 +1,47 @@
1SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.bitbucket.org/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
13DEPENDS = "freetype libpng jpeg zlib tiff"
14
15SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \
16 file://fix-gcc-unused-functions.patch"
17
18SRCREV = "46ceef5970bf3a847ff61d1bdde7501d66c11d0c"
19
20S = "${WORKDIR}/git"
21
22inherit autotools binconfig gettext pkgconfig
23
24EXTRA_OECONF += " --disable-rpath \
25 --with-jpeg=${STAGING_LIBDIR}/.. \
26 --with-freetype=yes \
27 --without-fontconfig \
28 --without-webp \
29 --without-xpm \
30 --without-x \
31 "
32
33EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
34
35do_install_append() {
36 # cleanup buildpaths from gdlib.pc
37 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
38}
39
40PACKAGES += "${PN}-tools"
41
42FILES_${PN} = "${libdir}/lib*${SOLIBS}"
43FILES_${PN}-tools = "${bindir}/*"
44
45PROVIDES += "${PN}-tools"
46RPROVIDES_${PN}-tools = "${PN}-tools"
47RDEPENDS_${PN}-tools = "perl perl-module-strict"