summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd/gd_2.1.0.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/gd/gd_2.1.0.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/gd/gd_2.1.0.bb')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.1.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.1.0.bb b/meta-oe/recipes-support/gd/gd_2.1.0.bb
new file mode 100644
index 000000000..f03b9b08b
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.1.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.bitbucket.org/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
13DEPENDS = "freetype libpng jpeg zlib tiff libvpx"
14
15SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2 \
16 file://fix-the-subdir-objects-error.patch \
17"
18SRC_URI[md5sum] = "5a1d5bab3a4a41d9f111bcceee4ad25b"
19SRC_URI[sha256sum] = "f3e1bc472bd81ee976a739436659fe752a14727a964c64530fde68531ddeee91"
20
21S = "${WORKDIR}/libgd-${PV}"
22
23inherit autotools binconfig gettext pkgconfig
24
25EXTRA_OECONF += " --disable-rpath \
26 --with-jpeg=${STAGING_LIBDIR}/.. \
27 --with-freetype=yes \
28 --without-fontconfig \
29 --without-xpm \
30 --without-x"
31
32EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
33
34PACKAGES += "${PN}-tools"
35
36FILES_${PN} = "${libdir}/lib*${SOLIBS}"
37FILES_${PN}-tools = "${bindir}/*"
38
39PROVIDES += "${PN}-tools"
40RPROVIDES_${PN}-tools = "${PN}-tools"
41RDEPENDS_${PN}-tools = "perl perl-module-strict"