diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2011-05-03 12:51:04 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-05-10 08:55:54 +0200 |
commit | 0ad2163130ffe3657cc1f52d1c4dadf1a3bc996e (patch) | |
tree | 26f707f980b32ec3c7604e3dd594cbae2a43828a /meta-oe/recipes-support/freerdp | |
parent | 2c7a05b09170dcac9b5f836fddfd0806208e5b17 (diff) | |
download | meta-openembedded-0ad2163130ffe3657cc1f52d1c4dadf1a3bc996e.tar.gz |
freerdp: add recipe based on GIT from 2009-03-29
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta-oe/recipes-support/freerdp')
-rw-r--r-- | meta-oe/recipes-support/freerdp/freerdp.inc | 24 | ||||
-rw-r--r-- | meta-oe/recipes-support/freerdp/freerdp_git.bb | 15 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp.inc b/meta-oe/recipes-support/freerdp/freerdp.inc new file mode 100644 index 000000000..f8402c71d --- /dev/null +++ b/meta-oe/recipes-support/freerdp/freerdp.inc | |||
@@ -0,0 +1,24 @@ | |||
1 | # Copyright (C) 2010, 2011 O.S. Systems Software Ltda. All Rights Reserved | ||
2 | # Released under the MIT license | ||
3 | |||
4 | DESCRIPTION = "FreeRDP RDP client" | ||
5 | HOMEPAGE = "http://freerdp.sourceforge.net" | ||
6 | DEPENDS = "virtual/libx11 openssl libxcursor cups alsa-lib" | ||
7 | SECTION = "x11/network" | ||
8 | LICENSE = "Apache-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
10 | |||
11 | INC_PR = "r0" | ||
12 | |||
13 | inherit pkgconfig autotools | ||
14 | |||
15 | do_configure_prepend() { | ||
16 | # workaround gcc linking bug | ||
17 | find ${S} -name 'Makefile.am' | xargs -n 1 sed 's,-pthread,-lpthread -D_REENTRANT,g' -i | ||
18 | } | ||
19 | |||
20 | do_install_append() { | ||
21 | rm ${D}${libdir}/freerdp/*.a ${D}${libdir}/freerdp/*.la | ||
22 | } | ||
23 | |||
24 | RDEPENDS_${PN} += "xprop" | ||
diff --git a/meta-oe/recipes-support/freerdp/freerdp_git.bb b/meta-oe/recipes-support/freerdp/freerdp_git.bb new file mode 100644 index 000000000..fa4ba9ae2 --- /dev/null +++ b/meta-oe/recipes-support/freerdp/freerdp_git.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # Copyright (C) 2010, 2011, O.S. Systems Software Ltda. | ||
2 | # Released under the MIT license | ||
3 | |||
4 | include freerdp.inc | ||
5 | |||
6 | inherit gitpkgv | ||
7 | |||
8 | PV = "gitr${SRCPV}" | ||
9 | PKGV = "${GITPKGVTAG}" | ||
10 | PR = "${INC_PR}.0" | ||
11 | |||
12 | SRCREV = "7bbde4fb3bc3a781364d0a626c49bc165cc507fd" | ||
13 | SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;protocol=git" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||