diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2012-07-30 23:52:49 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2012-07-31 00:14:55 +0200 |
commit | 4339668ff27c839af1a1e4cfa5a2d034afe204f2 (patch) | |
tree | d2a48dca9a2a46a944e5091bf9b157cb2dc15e44 /meta-oe/recipes-support/fltk | |
parent | f2afdd2b988af8d0b4d822c7c03529b725fe24ba (diff) | |
download | meta-openembedded-4339668ff27c839af1a1e4cfa5a2d034afe204f2.tar.gz |
fbreader, fltk, gpm, iksemel, joe, links, ode, openldap, opensync, xchat: import from meta-smartphone
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fltk')
-rw-r--r-- | meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch | 13 | ||||
-rw-r--r-- | meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch | 13 | ||||
-rw-r--r-- | meta-oe/recipes-support/fltk/fltk_1.1.10.bb | 37 |
3 files changed, 63 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch new file mode 100644 index 000000000..8c01a1f80 --- /dev/null +++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: fltk-1.1.9/Makefile | ||
2 | =================================================================== | ||
3 | --- fltk-1.1.9.orig/Makefile 2008-06-06 16:14:11.936736201 +0200 | ||
4 | +++ fltk-1.1.9/Makefile 2008-06-06 16:14:22.526357637 +0200 | ||
5 | @@ -27,7 +27,7 @@ | ||
6 | |||
7 | include makeinclude | ||
8 | |||
9 | -DIRS = $(IMAGEDIRS) src fluid test documentation | ||
10 | +DIRS = $(IMAGEDIRS) src fluid documentation | ||
11 | |||
12 | all: makeinclude fltk-config | ||
13 | for dir in $(DIRS); do\ | ||
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch new file mode 100644 index 000000000..867e9efcb --- /dev/null +++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | src/fl_set_fonts_xft.cxx is using fontconfig symbols | ||
2 | |||
3 | --- a/makeinclude.in 2012-01-26 18:09:58.628799060 +0100 | ||
4 | +++ b/makeinclude.in 2012-01-26 18:08:58.115801758 +0100 | ||
5 | @@ -81,7 +81,7 @@ | ||
6 | AUDIOLIBS = @AUDIOLIBS@ | ||
7 | DSOFLAGS = -L. @DSOFLAGS@ | ||
8 | LDFLAGS = $(OPTIM) @LDFLAGS@ | ||
9 | -LDLIBS = @LIBS@ | ||
10 | +LDLIBS = @LIBS@ -lfontconfig | ||
11 | GLDLIBS = @GLLIB@ @LIBS@ | ||
12 | LINKFLTK = @LINKFLTK@ | ||
13 | LINKFLTKGL = @LINKFLTKGL@ | ||
diff --git a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb new file mode 100644 index 000000000..2611b2065 --- /dev/null +++ b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit" | ||
2 | HOMEPAGE = "http://www.fltk.org" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "LGPLv2 & FLTK" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=1c0b73db66884b6a925e727400315130" | ||
6 | |||
7 | DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft" | ||
8 | |||
9 | SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2 \ | ||
10 | file://disable_test.patch \ | ||
11 | file://dso-fix.patch \ | ||
12 | " | ||
13 | |||
14 | S = "${WORKDIR}/fltk-${PV}" | ||
15 | |||
16 | inherit lib_package autotools binconfig | ||
17 | |||
18 | TARGET_CC_ARCH += "${LDFLAGS} -DXFT_MAJOR=2" | ||
19 | |||
20 | EXTRA_OECONF = "--enable-shared \ | ||
21 | --enable-threads \ | ||
22 | --enable-xdbe --enable-xft --enable-gl \ | ||
23 | --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}" | ||
24 | |||
25 | do_configure() { | ||
26 | oe_runconf | ||
27 | } | ||
28 | |||
29 | python populate_packages_prepend () { | ||
30 | if (bb.data.getVar('DEBIAN_NAMES', d, 1)): | ||
31 | bb.data.setVar('PKG_${PN}', 'libfltk${PV}', d) | ||
32 | } | ||
33 | |||
34 | LEAD_SONAME = "libfltk.so" | ||
35 | |||
36 | SRC_URI[md5sum] = "a1765594bc427ff892e36089fe1fa672" | ||
37 | SRC_URI[sha256sum] = "37ada22bf2586b8dd30d84209b8b58bdcb864627e5d02ae3f2c323a29261b19a" | ||