summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fltk
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/fltk
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/fltk')
-rw-r--r--meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch13
-rw-r--r--meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch13
-rw-r--r--meta-oe/recipes-support/fltk/fltk-1.1.10/libpng15.patch61
-rw-r--r--meta-oe/recipes-support/fltk/fltk_1.1.10.bb40
4 files changed, 127 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch
new file mode 100644
index 000000000..8c01a1f80
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch
@@ -0,0 +1,13 @@
1Index: fltk-1.1.9/Makefile
2===================================================================
3--- fltk-1.1.9.orig/Makefile 2008-06-06 16:14:11.936736201 +0200
4+++ fltk-1.1.9/Makefile 2008-06-06 16:14:22.526357637 +0200
5@@ -27,7 +27,7 @@
6
7 include makeinclude
8
9-DIRS = $(IMAGEDIRS) src fluid test documentation
10+DIRS = $(IMAGEDIRS) src fluid documentation
11
12 all: makeinclude fltk-config
13 for dir in $(DIRS); do\
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch
new file mode 100644
index 000000000..867e9efcb
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch
@@ -0,0 +1,13 @@
1src/fl_set_fonts_xft.cxx is using fontconfig symbols
2
3--- a/makeinclude.in 2012-01-26 18:09:58.628799060 +0100
4+++ b/makeinclude.in 2012-01-26 18:08:58.115801758 +0100
5@@ -81,7 +81,7 @@
6 AUDIOLIBS = @AUDIOLIBS@
7 DSOFLAGS = -L. @DSOFLAGS@
8 LDFLAGS = $(OPTIM) @LDFLAGS@
9-LDLIBS = @LIBS@
10+LDLIBS = @LIBS@ -lfontconfig
11 GLDLIBS = @GLLIB@ @LIBS@
12 LINKFLTK = @LINKFLTK@
13 LINKFLTKGL = @LINKFLTKGL@
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/libpng15.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/libpng15.patch
new file mode 100644
index 000000000..b2eb8d6fd
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/libpng15.patch
@@ -0,0 +1,61 @@
1Imported from gentoo
2http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/x11-libs/fltk/files/fltk-1.1.10-libpng15.patch
3
4--- a/src/Fl_PNG_Image.cxx
5+++ b/src/Fl_PNG_Image.cxx
6@@ -66,7 +66,8 @@ Fl_PNG_Image::Fl_PNG_Image(const char *png) // I - File to read
7 png_structp pp; // PNG read pointer
8 png_infop info; // PNG info pointers
9 png_bytep *rows; // PNG row pointers
10-
11+ png_byte color_type; // PNG color type
12+ png_byte bit_depth; // PNG bit depth
13
14 // Open the PNG file...
15 if ((fp = fopen(png, "rb")) == NULL) return;
16@@ -75,7 +76,7 @@ Fl_PNG_Image::Fl_PNG_Image(const char *png) // I - File to read
17 pp = png_create_read_struct(PNG_LIBPNG_VER_STRING, NULL, NULL, NULL);
18 info = png_create_info_struct(pp);
19
20- if (setjmp(pp->jmpbuf))
21+ if (setjmp(png_jmpbuf(pp)))
22 {
23 Fl::warning("PNG file \"%s\" contains errors!\n", png);
24 return;
25@@ -86,28 +87,24 @@ Fl_PNG_Image::Fl_PNG_Image(const char *png) // I - File to read
26
27 // Get the image dimensions and convert to grayscale or RGB...
28 png_read_info(pp, info);
29+ color_type = png_get_color_type(pp, info);
30
31- if (info->color_type == PNG_COLOR_TYPE_PALETTE)
32+ if (color_type == PNG_COLOR_TYPE_PALETTE)
33 png_set_expand(pp);
34
35- if (info->color_type & PNG_COLOR_MASK_COLOR)
36- channels = 3;
37- else
38- channels = 1;
39-
40- if ((info->color_type & PNG_COLOR_MASK_ALPHA) || info->num_trans)
41- channels ++;
42+ channels = png_get_channels(pp, info);
43
44- w((int)(info->width));
45- h((int)(info->height));
46+ w((int)(png_get_image_width(pp, info)));
47+ h((int)(png_get_image_height(pp, info)));
48 d(channels);
49
50- if (info->bit_depth < 8)
51+ bit_depth = png_get_bit_depth(pp, info);
52+ if (bit_depth < 8)
53 {
54 png_set_packing(pp);
55 png_set_expand(pp);
56 }
57- else if (info->bit_depth == 16)
58+ else if (bit_depth == 16)
59 png_set_strip_16(pp);
60
61 # if defined(HAVE_PNG_GET_VALID) && defined(HAVE_PNG_SET_TRNS_TO_ALPHA)
diff --git a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
new file mode 100644
index 000000000..fa0145531
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
@@ -0,0 +1,40 @@
1SUMMARY = "FLTK is a cross-platform C++ GUI toolkit"
2HOMEPAGE = "http://www.fltk.org"
3SECTION = "libs"
4LICENSE = "LGPLv2 & FLTK"
5LIC_FILES_CHKSUM = "file://COPYING;md5=1c0b73db66884b6a925e727400315130"
6
7DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
8
9PR = "r1"
10
11SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2 \
12 file://disable_test.patch \
13 file://dso-fix.patch \
14 file://libpng15.patch \
15"
16
17S = "${WORKDIR}/fltk-${PV}"
18
19inherit lib_package autotools-brokensep binconfig
20
21TARGET_CC_ARCH += "${LDFLAGS} -DXFT_MAJOR=2"
22
23EXTRA_OECONF = "--enable-shared \
24 --enable-threads \
25 --enable-xdbe --enable-xft --enable-gl \
26 --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
27
28do_configure() {
29 oe_runconf
30}
31
32python populate_packages_prepend () {
33 if (d.getVar('DEBIAN_NAMES', 1)):
34 d.setVar('PKG_${PN}', 'libfltk${PV}')
35}
36
37LEAD_SONAME = "libfltk.so"
38
39SRC_URI[md5sum] = "a1765594bc427ff892e36089fe1fa672"
40SRC_URI[sha256sum] = "37ada22bf2586b8dd30d84209b8b58bdcb864627e5d02ae3f2c323a29261b19a"