diff options
author | Paul Barker <paul@paulbarker.me.uk> | 2014-04-14 12:37:50 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-04-20 11:30:15 +0200 |
commit | 66d3a7ba3a4efa59cd83d8aab734b1434a3481f3 (patch) | |
tree | 77a6e07c6537cc06f33a20e8600d1e9c6172ea4f /meta-oe/recipes-support/fftw | |
parent | 76b0893ddb713cb575e92cac456ed3081840dd47 (diff) | |
download | meta-openembedded-66d3a7ba3a4efa59cd83d8aab734b1434a3481f3.tar.gz |
fftw: Refactor EXTRA_OECONF
The configure flags common to all three fftw recipes are moved into fftw.inc and
then each recipe just appends the extra flags it needs. This makes it easier to
read and modify options which affect all three recipes.
Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fftw')
-rw-r--r-- | meta-oe/recipes-support/fftw/fftw.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/fftw/fftw_3.3.3.bb | 3 | ||||
-rw-r--r-- | meta-oe/recipes-support/fftw/fftwf_3.3.3.bb | 4 | ||||
-rw-r--r-- | meta-oe/recipes-support/fftw/fftwl_3.3.3.bb | 3 |
4 files changed, 4 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/fftw/fftw.inc b/meta-oe/recipes-support/fftw/fftw.inc index 074a53b36..6bd622d9b 100644 --- a/meta-oe/recipes-support/fftw/fftw.inc +++ b/meta-oe/recipes-support/fftw/fftw.inc | |||
@@ -11,6 +11,8 @@ S = "${WORKDIR}/fftw-${PV}" | |||
11 | 11 | ||
12 | inherit autotools pkgconfig | 12 | inherit autotools pkgconfig |
13 | 13 | ||
14 | EXTRA_OECONF = "--disable-fortran --enable-shared --enable-threads" | ||
15 | |||
14 | do_configure_prepend() { | 16 | do_configure_prepend() { |
15 | echo 'AM_PROG_AS' >> ${S}/configure.ac | 17 | echo 'AM_PROG_AS' >> ${S}/configure.ac |
16 | } | 18 | } |
diff --git a/meta-oe/recipes-support/fftw/fftw_3.3.3.bb b/meta-oe/recipes-support/fftw/fftw_3.3.3.bb index 03a12746d..b889c910f 100644 --- a/meta-oe/recipes-support/fftw/fftw_3.3.3.bb +++ b/meta-oe/recipes-support/fftw/fftw_3.3.3.bb | |||
@@ -1,7 +1,4 @@ | |||
1 | require fftw.inc | 1 | require fftw.inc |
2 | 2 | ||
3 | EXTRA_OECONF = "--disable-fortran --enable-shared --enable-threads" | ||
4 | |||
5 | SRC_URI[md5sum] = "0a05ca9c7b3bfddc8278e7c40791a1c2" | 3 | SRC_URI[md5sum] = "0a05ca9c7b3bfddc8278e7c40791a1c2" |
6 | SRC_URI[sha256sum] = "85cdfc0a0ba10d8fa4f0f8e733aac1a5936c859832a9e3d5c0731fb5c54a97f3" | 4 | SRC_URI[sha256sum] = "85cdfc0a0ba10d8fa4f0f8e733aac1a5936c859832a9e3d5c0731fb5c54a97f3" |
7 | |||
diff --git a/meta-oe/recipes-support/fftw/fftwf_3.3.3.bb b/meta-oe/recipes-support/fftw/fftwf_3.3.3.bb index e2989d6e3..5e4e8edf7 100644 --- a/meta-oe/recipes-support/fftw/fftwf_3.3.3.bb +++ b/meta-oe/recipes-support/fftw/fftwf_3.3.3.bb | |||
@@ -1,10 +1,8 @@ | |||
1 | require fftw.inc | 1 | require fftw.inc |
2 | 2 | ||
3 | EXTRA_OECONF = "--disable-fortran --enable-single --enable-shared \ | 3 | EXTRA_OECONF += "--enable-single \ |
4 | --enable-threads \ | ||
5 | ${@base_contains('TUNE_FEATURES', 'neon', '--enable-neon', '', d)} \ | 4 | ${@base_contains('TUNE_FEATURES', 'neon', '--enable-neon', '', d)} \ |
6 | " | 5 | " |
7 | 6 | ||
8 | SRC_URI[md5sum] = "0a05ca9c7b3bfddc8278e7c40791a1c2" | 7 | SRC_URI[md5sum] = "0a05ca9c7b3bfddc8278e7c40791a1c2" |
9 | SRC_URI[sha256sum] = "85cdfc0a0ba10d8fa4f0f8e733aac1a5936c859832a9e3d5c0731fb5c54a97f3" | 8 | SRC_URI[sha256sum] = "85cdfc0a0ba10d8fa4f0f8e733aac1a5936c859832a9e3d5c0731fb5c54a97f3" |
10 | |||
diff --git a/meta-oe/recipes-support/fftw/fftwl_3.3.3.bb b/meta-oe/recipes-support/fftw/fftwl_3.3.3.bb index b28784ea1..9c673541f 100644 --- a/meta-oe/recipes-support/fftw/fftwl_3.3.3.bb +++ b/meta-oe/recipes-support/fftw/fftwl_3.3.3.bb | |||
@@ -1,7 +1,6 @@ | |||
1 | require fftw.inc | 1 | require fftw.inc |
2 | 2 | ||
3 | EXTRA_OECONF = "--disable-fortran --enable-long-double --enable-shared --enable-threads" | 3 | EXTRA_OECONF += "--enable-long-double" |
4 | 4 | ||
5 | SRC_URI[md5sum] = "0a05ca9c7b3bfddc8278e7c40791a1c2" | 5 | SRC_URI[md5sum] = "0a05ca9c7b3bfddc8278e7c40791a1c2" |
6 | SRC_URI[sha256sum] = "85cdfc0a0ba10d8fa4f0f8e733aac1a5936c859832a9e3d5c0731fb5c54a97f3" | 6 | SRC_URI[sha256sum] = "85cdfc0a0ba10d8fa4f0f8e733aac1a5936c859832a9e3d5c0731fb5c54a97f3" |
7 | |||