summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbset
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-04-10 13:24:47 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-04-10 14:43:41 +0200
commit89500c583e0f1dc1b4ffdf72914e08e505e427e0 (patch)
treeb073036cc61aa34ca5ac9eec4d617366e0dcb3d5 /meta-oe/recipes-support/fbset
parente66079da37992abd54486488aa06a99bf7a4198c (diff)
downloadmeta-openembedded-89500c583e0f1dc1b4ffdf72914e08e505e427e0.tar.gz
recipes,classes: import a lot of recipes from meta-shr
* tested on shr-lite-image for om-gta02 and nokia900 (with meta-shr layer)
Diffstat (limited to 'meta-oe/recipes-support/fbset')
-rw-r--r--meta-oe/recipes-support/fbset/fbset-2.1/makefile.patch11
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes.bb17
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes/fb.modes3
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes/om-gta01/fb.modes29
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes/omap3-pandora/fb.modes6
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes/qemuarm/fb.modes17
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes/qemumips/fb.modes17
-rw-r--r--meta-oe/recipes-support/fbset/fbset_2.1.bb38
8 files changed, 138 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset-2.1/makefile.patch b/meta-oe/recipes-support/fbset/fbset-2.1/makefile.patch
new file mode 100644
index 000000000..82b1c61e9
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-2.1/makefile.patch
@@ -0,0 +1,11 @@
1--- fbset-2.1/Makefile.orig 2006-05-28 04:04:27.412095480 +0200
2+++ fbset-2.1/Makefile 2006-05-28 04:14:05.379231120 +0200
3@@ -2,7 +2,7 @@
4 # Linux Frame Buffer Device Configuration
5 #
6
7-CC = gcc -Wall -O2 -I.
8+CFLAGS = -Wall -O2 -I.
9 BISON = bison -d
10 FLEX = flex
11 INSTALL = install
diff --git a/meta-oe/recipes-support/fbset/fbset-modes.bb b/meta-oe/recipes-support/fbset/fbset-modes.bb
new file mode 100644
index 000000000..415c00bab
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-modes.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "Default display timings and resolutions for fbset"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${TOPDIR}/meta-shr/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5PV = "0.1.0"
6PR = "r5"
7
8SRC_URI = "file://fb.modes"
9
10do_install() {
11 install -d ${D}${sysconfdir}
12 install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}
13}
14
15PACKAGE_ARCH = "all"
16CONFFILES_${PN} = "${sysconfdir}/fb.modes"
17
diff --git a/meta-oe/recipes-support/fbset/fbset-modes/fb.modes b/meta-oe/recipes-support/fbset/fbset-modes/fb.modes
new file mode 100644
index 000000000..ba5e6ed71
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-modes/fb.modes
@@ -0,0 +1,3 @@
1# By default there is nothing in this file just a reminder to define some
2# modes in OE
3
diff --git a/meta-oe/recipes-support/fbset/fbset-modes/om-gta01/fb.modes b/meta-oe/recipes-support/fbset/fbset-modes/om-gta01/fb.modes
new file mode 100644
index 000000000..446d23dd8
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-modes/om-gta01/fb.modes
@@ -0,0 +1,29 @@
1# Timings for GTA01 VGA and QVGA mode
2
3mode "480x640"
4 # D: 26.000 MHz, H: 43.334 kHz, V: 65.657 Hz
5 geometry 480 640 480 640 16
6 timings 38461 104 8 2 16 8 2
7 accel false
8endmode
9
10mode "vga"
11 # D: 26.000 MHz, H: 43.334 kHz, V: 65.657 Hz
12 geometry 480 640 480 640 16
13 timings 38461 104 8 2 16 8 2
14 accel false
15endmode
16
17mode "240x320"
18 # D: 8.475 MHz, H: 24.635 kHz, V: 75.569 Hz
19 geometry 240 320 240 320 16
20 timings 118000 88 8 2 2 8 2
21 accel false
22endmode
23
24mode "qvga"
25 # D: 8.475 MHz, H: 24.635 kHz, V: 75.569 Hz
26 geometry 240 320 240 320 16
27 timings 118000 88 8 2 2 8 2
28 accel false
29endmode
diff --git a/meta-oe/recipes-support/fbset/fbset-modes/omap3-pandora/fb.modes b/meta-oe/recipes-support/fbset/fbset-modes/omap3-pandora/fb.modes
new file mode 100644
index 000000000..0c87401b5
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-modes/omap3-pandora/fb.modes
@@ -0,0 +1,6 @@
1mode "800x480-65"
2 # D: 36.001 MHz, H: 34.124 kHz, V: 64.998 Hz
3 geometry 800 480 800 480 16
4 timings 27777 40 214 10 34 1 1
5 rgba 5/11,6/5,5/0,0/0
6endmode
diff --git a/meta-oe/recipes-support/fbset/fbset-modes/qemuarm/fb.modes b/meta-oe/recipes-support/fbset/fbset-modes/qemuarm/fb.modes
new file mode 100644
index 000000000..111456479
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-modes/qemuarm/fb.modes
@@ -0,0 +1,17 @@
1# QEMU versatilepb machine, qemuarm in OE
2
3mode "vga" "640x480"
4 geometry 640 480 640 480 16
5endmode
6
7mode "vga-portrait" "480x640"
8 geometry 480 640 480 640 16
9endmode
10
11mode "qvga" "320x240"
12 geometry 320 240 320 240 16
13endmode
14
15mode "qvga-portrait" "240x320"
16 geometry 240 320 240 320 16
17endmode
diff --git a/meta-oe/recipes-support/fbset/fbset-modes/qemumips/fb.modes b/meta-oe/recipes-support/fbset/fbset-modes/qemumips/fb.modes
new file mode 100644
index 000000000..111456479
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-modes/qemumips/fb.modes
@@ -0,0 +1,17 @@
1# QEMU versatilepb machine, qemuarm in OE
2
3mode "vga" "640x480"
4 geometry 640 480 640 480 16
5endmode
6
7mode "vga-portrait" "480x640"
8 geometry 480 640 480 640 16
9endmode
10
11mode "qvga" "320x240"
12 geometry 320 240 320 240 16
13endmode
14
15mode "qvga-portrait" "240x320"
16 geometry 240 320 240 320 16
17endmode
diff --git a/meta-oe/recipes-support/fbset/fbset_2.1.bb b/meta-oe/recipes-support/fbset/fbset_2.1.bb
new file mode 100644
index 000000000..12c1c944e
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset_2.1.bb
@@ -0,0 +1,38 @@
1#
2# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
3# License: MIT (see http://www.opensource.org/licenses/mit-license.php for a copy of the license)
4#
5# Filename: fbset_2.1.bb
6# Date: 28-May-06
7
8DESCRIPTION = "The fbset console tool"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://fbset.c;endline=19;md5=bf326f82cdfcac391af208f019c5603f"
11RRECOMMENDS_${PN} = "fbset-modes"
12DEPENDS = "bison-native"
13
14PR = "r4"
15
16SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \
17 file://makefile.patch"
18
19inherit autotools update-alternatives
20
21PARALLEL_MAKE = ""
22
23do_install() {
24 install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5
25 install -m 0755 ${WORKDIR}/${P}/fbset ${D}${sbindir}/fbset.real
26 install -m 0644 ${WORKDIR}/${P}/*.5 ${D}${datadir}/man/man5
27 install -m 0644 ${WORKDIR}/${P}/*.8 ${D}${datadir}/man/man8
28}
29
30ALTERNATIVE_NAME = "fbset"
31ALTERNATIVE_LINK = "${sbindir}/${ALTERNATIVE_NAME}"
32ALTERNATIVE_PATH = "${sbindir}/fbset.real"
33ALTERNATIVE_PRIORITY = "55"
34
35
36
37SRC_URI[md5sum] = "40ed9608f46d787bfb65fd1269f7f459"
38SRC_URI[sha256sum] = "517fa062d7b2d367f931a1c6ebb2bef84907077f0ce3f0c899e34490bbea9338"