summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbset
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-20 05:03:09 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:58:03 +0100
commit484fbf697925b116083925efdca211938e797c0f (patch)
treec1532a765ae713f9aa2fea80eae5082b5f16e55a /meta-oe/recipes-support/fbset
parent9cf9d864d57d2b431ad9c0a78c72e335451abe5b (diff)
downloadmeta-openembedded-484fbf697925b116083925efdca211938e797c0f.tar.gz
fbset: Fix out of tree builds ( S != B )
Remove assumption about glibc == linux Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fbset')
-rw-r--r--meta-oe/recipes-support/fbset/fbset/0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch34
-rw-r--r--meta-oe/recipes-support/fbset/fbset_2.1.bb7
2 files changed, 38 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset/0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch b/meta-oe/recipes-support/fbset/fbset/0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch
new file mode 100644
index 000000000..7f45dbea8
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset/0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch
@@ -0,0 +1,34 @@
1From 06edd88833da93361d5408b880fbb890df332497 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 19 Jan 2016 01:55:47 +0000
4Subject: [PATCH] fbset: including asm/types.h is needed on all linux systems
5
6including asm/types.h is needed to get Linux typedef's like
7__s32 and so on which are independent of C library therefore this
8define should not be guarded by __GLIBC__ but by __linux__
9
10Helps to compile it on musl systems
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14Upstream-Status: Pending
15
16 fbset.h | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/fbset.h b/fbset.h
20index 9b1d2ac..0d8def8 100644
21--- a/fbset.h
22+++ b/fbset.h
23@@ -15,7 +15,7 @@
24 #include <stdio.h>
25 #include <sys/types.h>
26
27-#ifdef __GLIBC__
28+#ifdef __linux__
29 #include <asm/types.h>
30 #endif
31
32--
332.7.0
34
diff --git a/meta-oe/recipes-support/fbset/fbset_2.1.bb b/meta-oe/recipes-support/fbset/fbset_2.1.bb
index 18559326a..cbbe6caee 100644
--- a/meta-oe/recipes-support/fbset/fbset_2.1.bb
+++ b/meta-oe/recipes-support/fbset/fbset_2.1.bb
@@ -16,15 +16,16 @@ PR = "r4"
16SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \ 16SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \
17 file://makefile.patch \ 17 file://makefile.patch \
18 file://fbset-2.1-fix-makefile-dep.patch \ 18 file://fbset-2.1-fix-makefile-dep.patch \
19 file://0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch \
19" 20"
20 21
21inherit update-alternatives 22inherit update-alternatives
22 23
23do_install() { 24do_install() {
24 install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5 25 install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5
25 install -m 0755 ${WORKDIR}/${BP}/fbset ${D}${sbindir}/fbset.real 26 install -m 0755 ${B}/fbset ${D}${sbindir}/fbset.real
26 install -m 0644 ${WORKDIR}/${BP}/*.5 ${D}${datadir}/man/man5 27 install -m 0644 ${B}/*.5 ${D}${datadir}/man/man5
27 install -m 0644 ${WORKDIR}/${BP}/*.8 ${D}${datadir}/man/man8 28 install -m 0644 ${B}/*.8 ${D}${datadir}/man/man8
28} 29}
29 30
30ALTERNATIVE_fbset = "fbset" 31ALTERNATIVE_fbset = "fbset"