summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbset
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-04-09 15:50:26 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 13:42:06 +0200
commit37008a7a8c25688eb9e6bba7f1bb1d91906feb6d (patch)
tree2e1337f5a7eb6e38c265586d238f2aa0685ddf80 /meta-oe/recipes-support/fbset
parent9fe857dd8d2814edfa3a5821ec5b409404f77591 (diff)
downloadmeta-openembedded-37008a7a8c25688eb9e6bba7f1bb1d91906feb6d.tar.gz
fbset: fix parallel build
Fix an incorrect dependency in makefile so that we can build in parallel. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fbset')
-rw-r--r--meta-oe/recipes-support/fbset/fbset-2.1/fbset-2.1-fix-makefile-dep.patch31
-rw-r--r--meta-oe/recipes-support/fbset/fbset_2.1.bb6
2 files changed, 34 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset-2.1/fbset-2.1-fix-makefile-dep.patch b/meta-oe/recipes-support/fbset/fbset-2.1/fbset-2.1-fix-makefile-dep.patch
new file mode 100644
index 000000000..41ab8af3d
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-2.1/fbset-2.1-fix-makefile-dep.patch
@@ -0,0 +1,31 @@
1From 3db6782de1de7ca4f1bb9ee7652c4f2808e57539 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Thu, 10 Jan 2013 12:24:33 +0800
4Subject: [PATCH] fbset 2.1 fix makefile dep modes.tab.c
5
6Upstream-Status: Inappropriate [no upstream]
7
8fix the error in parallel build:
9make: *** No rule to make target `modes.tab.h', needed by `lex.yy.o'. Stop.
10
11Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
12---
13 Makefile | 2 +-
14 1 files changed, 1 insertions(+), 1 deletions(-)
15
16diff --git a/Makefile b/Makefile
17index 61536c1..09183e5 100644
18--- a/Makefile
19+++ b/Makefile
20@@ -15,7 +15,7 @@ fbset: fbset.o modes.tab.o lex.yy.o
21
22 fbset.o: fbset.c fbset.h fb.h
23 modes.tab.o: modes.tab.c fbset.h fb.h
24-lex.yy.o: lex.yy.c fbset.h modes.tab.h
25+lex.yy.o: lex.yy.c fbset.h modes.tab.c
26
27 lex.yy.c: modes.l
28 $(FLEX) modes.l
29--
301.7.4.1
31
diff --git a/meta-oe/recipes-support/fbset/fbset_2.1.bb b/meta-oe/recipes-support/fbset/fbset_2.1.bb
index aa780081e..84f35ffa2 100644
--- a/meta-oe/recipes-support/fbset/fbset_2.1.bb
+++ b/meta-oe/recipes-support/fbset/fbset_2.1.bb
@@ -14,12 +14,12 @@ DEPENDS = "bison-native"
14PR = "r4" 14PR = "r4"
15 15
16SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \ 16SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \
17 file://makefile.patch" 17 file://makefile.patch \
18 file://fbset-2.1-fix-makefile-dep.patch \
19"
18 20
19inherit autotools update-alternatives 21inherit autotools update-alternatives
20 22
21PARALLEL_MAKE = ""
22
23do_install() { 23do_install() {
24 install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5 24 install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5
25 install -m 0755 ${WORKDIR}/${P}/fbset ${D}${sbindir}/fbset.real 25 install -m 0755 ${WORKDIR}/${P}/fbset ${D}${sbindir}/fbset.real