summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbset/fbset_2.1.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/fbset/fbset_2.1.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/fbset/fbset_2.1.bb')
-rw-r--r--meta-oe/recipes-support/fbset/fbset_2.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset_2.1.bb b/meta-oe/recipes-support/fbset/fbset_2.1.bb
new file mode 100644
index 000000000..18559326a
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset_2.1.bb
@@ -0,0 +1,36 @@
1#
2# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
3# License: MIT (see http://www.opensource.org/licenses/mit-license.php for a copy of the license)
4#
5# Filename: fbset_2.1.bb
6# Date: 28-May-06
7
8SUMMARY = "The fbset console tool"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://fbset.c;endline=19;md5=bf326f82cdfcac391af208f019c5603f"
11RRECOMMENDS_${PN} = "fbset-modes"
12DEPENDS = "bison-native flex-native"
13
14PR = "r4"
15
16SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \
17 file://makefile.patch \
18 file://fbset-2.1-fix-makefile-dep.patch \
19"
20
21inherit update-alternatives
22
23do_install() {
24 install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5
25 install -m 0755 ${WORKDIR}/${BP}/fbset ${D}${sbindir}/fbset.real
26 install -m 0644 ${WORKDIR}/${BP}/*.5 ${D}${datadir}/man/man5
27 install -m 0644 ${WORKDIR}/${BP}/*.8 ${D}${datadir}/man/man8
28}
29
30ALTERNATIVE_fbset = "fbset"
31ALTERNATIVE_LINK_NAME[fbset] = "${sbindir}/fbset"
32ALTERNATIVE_TARGET[fbset] = "${sbindir}/fbset.real"
33ALTERNATIVE_PRIORITY[fbset] = "55"
34
35SRC_URI[md5sum] = "40ed9608f46d787bfb65fd1269f7f459"
36SRC_URI[sha256sum] = "517fa062d7b2d367f931a1c6ebb2bef84907077f0ce3f0c899e34490bbea9338"