summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbset/fbset-modes.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/fbset/fbset-modes.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/fbset/fbset-modes.bb')
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset-modes.bb b/meta-oe/recipes-support/fbset/fbset-modes.bb
new file mode 100644
index 000000000..1310e6f7b
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-modes.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Default display timings and resolutions for fbset"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5PV = "0.1.0"
6PR = "r6"
7
8SRC_URI = "file://fb.modes"
9
10do_install() {
11 install -d ${D}${sysconfdir}
12 install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}
13}
14
15inherit allarch
16
17# fb.modes file is MACHINE_ARCH, base.bbclass correctly changes it to MACHINE_ARCH, but too late for allarch.bbclass
18# to disable "all" behavior (found when comparing qemuarm and qemux86 signatures)
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20
21CONFFILES_${PN} = "${sysconfdir}/fb.modes"