summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/farsight
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/farsight
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/farsight')
-rw-r--r--meta-oe/recipes-support/farsight/farsight2_0.0.22.bb31
-rw-r--r--meta-oe/recipes-support/farsight/libnice_0.0.13.bb41
2 files changed, 72 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb b/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb
new file mode 100644
index 000000000..beb610813
--- /dev/null
+++ b/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "FarSight is an audio/video conferencing framework specifically designed for Instant Messengers."
2HOMEPAGE = "http://farsight.sf.net"
3SRC_URI = "http://farsight.freedesktop.org/releases/farsight2/${BP}.tar.gz"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
7
8PR = "r3"
9
10DEPENDS = "libnice glib-2.0 libxml2 zlib dbus gstreamer gst-plugins-base"
11
12inherit autotools
13
14PACKAGECONFIG ??= ""
15PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
16
17EXTRA_OECONF = " \
18 --disable-debug \
19 --disable-gtk-doc \
20 --disable-python \
21"
22
23FILES_${PN} += "${libdir}/*/*.so"
24FILES_${PN}-dev += "${libdir}/*/*.la"
25FILES_${PN}-staticdev += "${libdir}/*/*.a"
26FILES_${PN}-dbg += "${libdir}/*/.debug"
27
28
29SRC_URI[md5sum] = "e1f540cf3ebab06c3d7db1f46b44ac88"
30SRC_URI[sha256sum] = "3ae59aa61a8071c9fad111e5fd606aabc27961eb4192f8729987a27dae6b3974"
31
diff --git a/meta-oe/recipes-support/farsight/libnice_0.0.13.bb b/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
new file mode 100644
index 000000000..711b6bdbf
--- /dev/null
+++ b/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Interactive Connectivity Establishment library"
2DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)."
3HOMEPAGE = "http://nice.freedesktop.org/wiki/"
4SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
5
6LICENSE = "LGPLv2.1 & MPLv1.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \
8 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
9 file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \
10"
11
12PR = "r4"
13
14DEPENDS = "glib-2.0 gstreamer"
15
16PACKAGECONFIG ??= ""
17PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
18
19inherit autotools pkgconfig gtk-doc
20
21FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
22FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la"
23FILES_${PN}-staticdev += "${libdir}/gstreamer-0.10/*.a"
24FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
25
26do_configure_prepend() {
27 mkdir ${S}/m4 || true
28}
29
30do_compile_append() {
31 for i in $(find ${S} -name "*.pc") ; do
32 sed -i -e s:${STAGING_DIR_TARGET}::g \
33 -e s:/${TARGET_SYS}::g \
34 $i
35 done
36}
37
38
39SRC_URI[md5sum] = "e5b9f799a57cb939ea2658ec35253ab9"
40SRC_URI[sha256sum] = "d8dd260c486a470a6052a5323920878a084e44a19df09b15728b85c9e3d6edf0"
41