summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/farsight/libnice_0.1.13.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-20 23:32:23 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-31 13:26:00 +0200
commitf646f52eac00e934dd47c86ea269f1e4b70fd080 (patch)
treebbc37bd317e5e445d5c383c4e29e89f5adb6fd28 /meta-oe/recipes-support/farsight/libnice_0.1.13.bb
parentaa4daa9990896c8d6092a7e655ac25a0ff2400b3 (diff)
downloadmeta-openembedded-f646f52eac00e934dd47c86ea269f1e4b70fd080.tar.gz
libnice: Upgrade to 0.1.13
works with gst1x therefore unblacklist Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/farsight/libnice_0.1.13.bb')
-rw-r--r--meta-oe/recipes-support/farsight/libnice_0.1.13.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/farsight/libnice_0.1.13.bb b/meta-oe/recipes-support/farsight/libnice_0.1.13.bb
new file mode 100644
index 000000000..48c8221a3
--- /dev/null
+++ b/meta-oe/recipes-support/farsight/libnice_0.1.13.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Interactive Connectivity Establishment library"
2DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)."
3HOMEPAGE = "http://nice.freedesktop.org/wiki/"
4SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
5SRC_URI[md5sum] = "3226faeaf48a9150ada00da2e2865959"
6SRC_URI[sha256sum] = "61112d9f3be933a827c8365f20551563953af6718057928f51f487bfe88419e1"
7
8LICENSE = "LGPLv2.1 & MPLv1.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \
10 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
11 file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \
12"
13
14DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base"
15
16PACKAGECONFIG ??= ""
17PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
18
19inherit autotools pkgconfig gtk-doc gobject-introspection
20
21FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
22FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la"
23FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
24FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
25
26do_configure_prepend() {
27 mkdir ${S}/m4 || true
28}
29
30do_compile_append() {
31 for i in $(find ${B} -name "*.pc") ; do
32 sed -i -e s:${STAGING_DIR_TARGET}::g \
33 -e s:/${TARGET_SYS}::g \
34 $i
35 done
36}