summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/espeak
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/espeak
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/espeak')
-rw-r--r--meta-oe/recipes-support/espeak/espeak-data_1.37.bb18
-rw-r--r--meta-oe/recipes-support/espeak/espeak_1.37.bb40
2 files changed, 29 insertions, 29 deletions
diff --git a/meta-oe/recipes-support/espeak/espeak-data_1.37.bb b/meta-oe/recipes-support/espeak/espeak-data_1.37.bb
index d15d49690..914bf3601 100644
--- a/meta-oe/recipes-support/espeak/espeak-data_1.37.bb
+++ b/meta-oe/recipes-support/espeak/espeak-data_1.37.bb
@@ -9,18 +9,18 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
9TARGET_ARCH = "${MACHINE_ARCH}" 9TARGET_ARCH = "${MACHINE_ARCH}"
10 10
11do_compile() { 11do_compile() {
12 # Fixing byte order of phoneme data files 12 # Fixing byte order of phoneme data files
13 cd "${S}/platforms/big_endian" 13 cd "${S}/platforms/big_endian"
14 sed -i '/^ *CC *=/d' Makefile 14 sed -i '/^ *CC *=/d' Makefile
15 sed -i 's/\(.*BYTE_ORDER\)/#undef BYTE_ORDER\n#define BYTE_ORDER BIG_ENDIAN\n\1/' espeak-phoneme-data.c 15 sed -i 's/\(.*BYTE_ORDER\)/#undef BYTE_ORDER\n#define BYTE_ORDER BIG_ENDIAN\n\1/' espeak-phoneme-data.c
16 oe_runmake 16 oe_runmake
17 ./espeak-phoneme-data "${S}/espeak-data" 17 ./espeak-phoneme-data "${S}/espeak-data"
18 cp -f phondata phonindex phontab "${S}/espeak-data" 18 cp -f phondata phonindex phontab "${S}/espeak-data"
19} 19}
20 20
21do_install() { 21do_install() {
22 install -d ${D}${layout_datadir}/espeak-data 22 install -d ${D}${layout_datadir}/espeak-data
23 install -m 0644 ${S}/espeak-data/phon* ${D}${layout_datadir}/espeak-data 23 install -m 0644 ${S}/espeak-data/phon* ${D}${layout_datadir}/espeak-data
24} 24}
25 25
26SRC_URI[md5sum] = "5c7b292d0537232868b4ac1317d76c02" 26SRC_URI[md5sum] = "5c7b292d0537232868b4ac1317d76c02"
diff --git a/meta-oe/recipes-support/espeak/espeak_1.37.bb b/meta-oe/recipes-support/espeak/espeak_1.37.bb
index 6cc4cd410..c7f4b521c 100644
--- a/meta-oe/recipes-support/espeak/espeak_1.37.bb
+++ b/meta-oe/recipes-support/espeak/espeak_1.37.bb
@@ -13,30 +13,30 @@ TARGET_CC_ARCH += "${LDFLAGS}"
13FILES_${PN} += "${datadir}/espeak-data" 13FILES_${PN} += "${datadir}/espeak-data"
14 14
15do_configure() { 15do_configure() {
16 # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19 16 # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
17 cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h" 17 cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
18} 18}
19 19
20do_compile() { 20do_compile() {
21 cd src 21 cd src
22 oe_runmake 22 oe_runmake
23} 23}
24 24
25do_install() { 25do_install() {
26 install -d ${D}${bindir} 26 install -d ${D}${bindir}
27 install -d ${D}${libdir} 27 install -d ${D}${libdir}
28 install -d ${D}${includedir} 28 install -d ${D}${includedir}
29 install -d ${D}${datadir}/espeak-data 29 install -d ${D}${datadir}/espeak-data
30 30
31 # we do not ship "speak" binary though. 31 # we do not ship "speak" binary though.
32 install -m 0755 ${S}/src/espeak ${D}${bindir} 32 install -m 0755 ${S}/src/espeak ${D}${bindir}
33 install -m 0644 ${S}/src/speak_lib.h ${D}${includedir} 33 install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
34 oe_libinstall -so -C src libespeak ${D}${libdir} 34 oe_libinstall -so -C src libespeak ${D}${libdir}
35 35
36 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then 36 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
37 # the big-endian phon* files are provided by the package espeak-data 37 # the big-endian phon* files are provided by the package espeak-data
38 rm -f ${S}/espeak-data/phon* 38 rm -f ${S}/espeak-data/phon*
39 fi 39 fi
40 40
41 cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data 41 cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
42} 42}