summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/espeak
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/espeak
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/espeak')
-rw-r--r--meta-oe/recipes-support/espeak/espeak-data_1.37.bb27
-rw-r--r--meta-oe/recipes-support/espeak/espeak.inc10
-rw-r--r--meta-oe/recipes-support/espeak/espeak_1.37.bb43
3 files changed, 80 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/espeak/espeak-data_1.37.bb b/meta-oe/recipes-support/espeak/espeak-data_1.37.bb
new file mode 100644
index 000000000..914bf3601
--- /dev/null
+++ b/meta-oe/recipes-support/espeak/espeak-data_1.37.bb
@@ -0,0 +1,27 @@
1require espeak.inc
2
3inherit native
4
5PACKAGES = "${PN}"
6FILES_${PN} = "${layout_datadir}"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9TARGET_ARCH = "${MACHINE_ARCH}"
10
11do_compile() {
12 # Fixing byte order of phoneme data files
13 cd "${S}/platforms/big_endian"
14 sed -i '/^ *CC *=/d' Makefile
15 sed -i 's/\(.*BYTE_ORDER\)/#undef BYTE_ORDER\n#define BYTE_ORDER BIG_ENDIAN\n\1/' espeak-phoneme-data.c
16 oe_runmake
17 ./espeak-phoneme-data "${S}/espeak-data"
18 cp -f phondata phonindex phontab "${S}/espeak-data"
19}
20
21do_install() {
22 install -d ${D}${layout_datadir}/espeak-data
23 install -m 0644 ${S}/espeak-data/phon* ${D}${layout_datadir}/espeak-data
24}
25
26SRC_URI[md5sum] = "5c7b292d0537232868b4ac1317d76c02"
27SRC_URI[sha256sum] = "77f406c345362185ec4f362bf49f61d202e01ac9b9cd5c14f803195a544ce6d3"
diff --git a/meta-oe/recipes-support/espeak/espeak.inc b/meta-oe/recipes-support/espeak/espeak.inc
new file mode 100644
index 000000000..98a17650f
--- /dev/null
+++ b/meta-oe/recipes-support/espeak/espeak.inc
@@ -0,0 +1,10 @@
1DESCRIPTION = "eSpeak is a compact open source software speech synthesizer"
2SECTION = "base"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://License.txt;md5=cb7a20edb4c9f5f478de6523dcd7362c"
5
6SRC_URI = "${SOURCEFORGE_MIRROR}/espeak/espeak-${PV}-source.zip"
7
8S = "${WORKDIR}/espeak-${PV}-source"
9
10DEPENDS = "portaudio-v19"
diff --git a/meta-oe/recipes-support/espeak/espeak_1.37.bb b/meta-oe/recipes-support/espeak/espeak_1.37.bb
new file mode 100644
index 000000000..86f2c7a76
--- /dev/null
+++ b/meta-oe/recipes-support/espeak/espeak_1.37.bb
@@ -0,0 +1,43 @@
1require espeak.inc
2inherit siteinfo
3
4EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANNESS", "be", "espeak-data (= ${PV})", "", d)}'
5RDEPENDS_${PN} = "portaudio-v19 ${EXTRA_PHONEMES}"
6
7SRC_URI[md5sum] = "5c7b292d0537232868b4ac1317d76c02"
8SRC_URI[sha256sum] = "77f406c345362185ec4f362bf49f61d202e01ac9b9cd5c14f803195a544ce6d3"
9
10CXXFLAGS += "-DUSE_PORTAUDIO"
11TARGET_CC_ARCH += "${LDFLAGS}"
12
13FILES_${PN} += "${datadir}/espeak-data"
14
15do_configure() {
16 # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
17 cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
18}
19
20do_compile() {
21 cd src
22 oe_runmake
23}
24
25do_install() {
26 install -d ${D}${bindir}
27 install -d ${D}${libdir}
28 install -d ${D}${includedir}/espeak
29 install -d ${D}${datadir}/espeak-data
30
31 # we do not ship "speak" binary though.
32 install -m 0755 ${S}/src/espeak ${D}${bindir}
33 install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}/espeak/
34 ln -sf espeak/espeak.h ${D}${includedir}/
35 oe_libinstall -so -C src libespeak ${D}${libdir}
36
37 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
38 # the big-endian phon* files are provided by the package espeak-data
39 rm -f ${S}/espeak-data/phon*
40 fi
41
42 cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
43}