summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/espeak/espeak_1.37.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-05-29 21:05:30 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-29 21:37:56 +0200
commitf71254a7ac97dea82c425b927255bcb3effafad0 (patch)
tree6c15d91142cc23c791ea3e73dfb760a094e3527d /meta-oe/recipes-support/espeak/espeak_1.37.bb
parent2bd740ea574d53ad83c073f93f48fe4e2a1d3edf (diff)
downloadmeta-openembedded-f71254a7ac97dea82c425b927255bcb3effafad0.tar.gz
espeak: import from OE rev d4f0211e2078d5033ae0dee74664de5520d8392d
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/espeak/espeak_1.37.bb')
-rw-r--r--meta-oe/recipes-support/espeak/espeak_1.37.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/espeak/espeak_1.37.bb b/meta-oe/recipes-support/espeak/espeak_1.37.bb
new file mode 100644
index 000000000..6cc4cd410
--- /dev/null
+++ b/meta-oe/recipes-support/espeak/espeak_1.37.bb
@@ -0,0 +1,42 @@
1require espeak.inc
2inherit siteinfo
3
4EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANNESS", "be", "espeak-data (= ${PV})", "", d)}'
5RDEPENDS_${PN} = "portaudio-v19 ${EXTRA_PHONEMES}"
6
7SRC_URI[md5sum] = "5c7b292d0537232868b4ac1317d76c02"
8SRC_URI[sha256sum] = "77f406c345362185ec4f362bf49f61d202e01ac9b9cd5c14f803195a544ce6d3"
9
10CXXFLAGS += "-DUSE_PORTAUDIO"
11TARGET_CC_ARCH += "${LDFLAGS}"
12
13FILES_${PN} += "${datadir}/espeak-data"
14
15do_configure() {
16 # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
17 cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
18}
19
20do_compile() {
21 cd src
22 oe_runmake
23}
24
25do_install() {
26 install -d ${D}${bindir}
27 install -d ${D}${libdir}
28 install -d ${D}${includedir}
29 install -d ${D}${datadir}/espeak-data
30
31 # we do not ship "speak" binary though.
32 install -m 0755 ${S}/src/espeak ${D}${bindir}
33 install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
34 oe_libinstall -so -C src libespeak ${D}${libdir}
35
36 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
37 # the big-endian phon* files are provided by the package espeak-data
38 rm -f ${S}/espeak-data/phon*
39 fi
40
41 cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
42}