summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/enca/enca_1.9.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/enca/enca_1.9.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/enca/enca_1.9.bb')
-rw-r--r--meta-oe/recipes-support/enca/enca_1.9.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/enca/enca_1.9.bb b/meta-oe/recipes-support/enca/enca_1.9.bb
new file mode 100644
index 000000000..bf19843b2
--- /dev/null
+++ b/meta-oe/recipes-support/enca/enca_1.9.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Enca is an Extremely Naive Charset Analyser"
2SECTION = "libs"
3HOMEPAGE = "http://trific.ath.cx/software/enca/"
4
5DEPENDS += "gettext-native"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=24b9569831c46d4818450b55282476b4"
9
10SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/enca-${PV}.tar.bz2 \
11 file://configure-hack.patch \
12 file://dont-run-tests.patch \
13 file://configure-remove-dumbness.patch \
14 file://makefile-remove-tools.patch \
15 file://libenca-003-iconv.patch "
16
17SRC_URI[md5sum] = "b3581e28d68d452286fb0bfe58bed3b3"
18SRC_URI[sha256sum] = "02acfef2b24a9c842612da49338138311f909f1cd33933520c07b8b26c410f4d"
19
20inherit autotools
21
22do_configure_prepend() {
23 # remove failing test which checks for something that isn't even used
24 sed -i -e '/ye_FUNC_SCANF_MODIF_SIZE_T/d' ${S}/configure.ac
25}
26
27do_configure_append() {
28 sed -i s:-I/usr/include::g ${B}/Makefile
29 sed -i s:-I/usr/include::g ${B}/*/Makefile
30}
31
32do_compile() {
33 cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c
34 cd ${B}
35 oe_runmake
36}
37