summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/emacs/emacs_27.2.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-support/emacs/emacs_27.2.bb
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/emacs/emacs_27.2.bb')
-rw-r--r--meta-oe/recipes-support/emacs/emacs_27.2.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/meta-oe/recipes-support/emacs/emacs_27.2.bb b/meta-oe/recipes-support/emacs/emacs_27.2.bb
index 01629f416..485d78ce4 100644
--- a/meta-oe/recipes-support/emacs/emacs_27.2.bb
+++ b/meta-oe/recipes-support/emacs/emacs_27.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
7SRC_URI = "https://ftp.gnu.org/pub/gnu/emacs/emacs-${PV}.tar.xz \ 7SRC_URI = "https://ftp.gnu.org/pub/gnu/emacs/emacs-${PV}.tar.xz \
8 file://emacs-glibc-2.34.patch \ 8 file://emacs-glibc-2.34.patch \
9 " 9 "
10SRC_URI_append_class-target = " file://usemake-docfile-native.patch" 10SRC_URI:append:class-target = " file://usemake-docfile-native.patch"
11 11
12SRC_URI[sha256sum] = "b4a7cc4e78e63f378624e0919215b910af5bb2a0afc819fad298272e9f40c1b9" 12SRC_URI[sha256sum] = "b4a7cc4e78e63f378624e0919215b910af5bb2a0afc819fad298272e9f40c1b9"
13 13
@@ -22,24 +22,24 @@ PACKAGECONFIG ??= "gnutls kerberos libgmp"
22EXTRA_OECONF = " --with-x=no --with-dumping=none" 22EXTRA_OECONF = " --with-x=no --with-dumping=none"
23 23
24DEPENDS = "ncurses" 24DEPENDS = "ncurses"
25DEPENDS_append_class-target = " emacs-native" 25DEPENDS:append:class-target = " emacs-native"
26 26
27inherit autotools mime-xdg 27inherit autotools mime-xdg
28 28
29 29
30do_compile_class-native (){ 30do_compile:class-native (){
31 cd ${B}/lib-src 31 cd ${B}/lib-src
32 oe_runmake make-docfile 32 oe_runmake make-docfile
33 oe_runmake make-fingerprint 33 oe_runmake make-fingerprint
34} 34}
35do_install_class-native(){ 35do_install:class-native(){
36 install -d ${D}${bindir} 36 install -d ${D}${bindir}
37 install -m 755 ${B}/lib-src/make-docfile ${D}/${bindir}/ 37 install -m 755 ${B}/lib-src/make-docfile ${D}/${bindir}/
38 install -m 755 ${B}/lib-src/make-fingerprint ${D}/${bindir}/ 38 install -m 755 ${B}/lib-src/make-fingerprint ${D}/${bindir}/
39} 39}
40 40
41 41
42do_install_append(){ 42do_install:append(){
43 # Delete systemd stuff, extend using DISTRO_FEATURES? 43 # Delete systemd stuff, extend using DISTRO_FEATURES?
44 rm -rf ${D}/${libdir} 44 rm -rf ${D}/${libdir}
45 # Extra stuff which isnt needed 45 # Extra stuff which isnt needed
@@ -59,13 +59,13 @@ do_install_append(){
59# The lists of files are long but are worth it 59# The lists of files are long but are worth it
60# Installing "emacs" installs the base package 60# Installing "emacs" installs the base package
61PACKAGE_BEFORE_PN = "${PN}-minimal ${PN}-base ${PN}-full" 61PACKAGE_BEFORE_PN = "${PN}-minimal ${PN}-base ${PN}-full"
62RPROVIDES_${PN}-base = "${PN}" 62RPROVIDES:${PN}-base = "${PN}"
63RDEPENDS_${PN}-base_class-target = "${PN}-minimal" 63RDEPENDS:${PN}-base:class-target = "${PN}-minimal"
64RDEPENDS_${PN}-full_class-target = "${PN}" 64RDEPENDS:${PN}-full:class-target = "${PN}"
65 65
66 66
67# A minimal version of emacs that works 67# A minimal version of emacs that works
68FILES_${PN}-minimal = " \ 68FILES:${PN}-minimal = " \
69 ${datadir}/${BPN}/${PV}/lisp/loadup.el \ 69 ${datadir}/${BPN}/${PV}/lisp/loadup.el \
70 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-run.elc \ 70 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-run.elc \
71 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/backquote.elc \ 71 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/backquote.elc \
@@ -185,7 +185,7 @@ FILES_${PN}-minimal = " \
185 185
186 186
187# What works for "most" is relative, but this can be easily extended if needed 187# What works for "most" is relative, but this can be easily extended if needed
188FILES_${PN}-base = " \ 188FILES:${PN}-base = " \
189 ${datadir}/${BPN}/${PV}/etc/srecode \ 189 ${datadir}/${BPN}/${PV}/etc/srecode \
190 ${datadir}/${BPN}/${PV}/etc/e \ 190 ${datadir}/${BPN}/${PV}/etc/e \
191 ${datadir}/${BPN}/${PV}/etc/forms \ 191 ${datadir}/${BPN}/${PV}/etc/forms \
@@ -253,8 +253,8 @@ FILES_${PN}-base = " \
253" 253"
254 254
255# Restore FILES for the full package to catch everything left 255# Restore FILES for the full package to catch everything left
256FILES_${PN}-full = "${FILES_${PN}}" 256FILES:${PN}-full = "${FILES_${PN}}"
257FILES_${PN}-full_append = " ${datadir}/icons" 257FILES:${PN}-full:append = " ${datadir}/icons"
258 258
259 259
260# The following does NOT build a native emacs. 260# The following does NOT build a native emacs.