summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/digitemp
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/digitemp
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/digitemp')
-rw-r--r--meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch20
-rw-r--r--meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb27
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch b/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch
new file mode 100644
index 000000000..c0d552d54
--- /dev/null
+++ b/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch
@@ -0,0 +1,20 @@
1digitemp: allow override of CC and CFLAGS vars
2
3Upstream-Status: Inappropriate [embedded specific]
4
5Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
6
7--- a/Makefile 2008-08-28 21:37:00.000000000 +0000
8+++ b/Makefile 2011-11-24 22:22:39.882511272 +0000
9@@ -11,8 +11,9 @@
10
11 VERSION = 3.6.0
12
13-CC = gcc
14-CFLAGS = -I./src -I./userial -O2 -Wall # -g
15+CC ?= gcc
16+CFLAGS ?= -O2 -Wall # -g
17+CFLAGS += -I./src -I./userial
18
19 OBJS = src/digitemp.o src/device_name.o src/ds2438.o
20 HDRS = src/digitemp.h src/device_name.h
diff --git a/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb b/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb
new file mode 100644
index 000000000..2582820e6
--- /dev/null
+++ b/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "read temperature sensors in a 1-Wire net"
2SECTION = "util"
3DEPENDS = "libusb1"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0"
6
7PR = "r2"
8
9SRC_URI = "http://www.digitemp.com/software/linux/digitemp-${PV}.tar.gz \
10 file://makefile-fix.patch"
11SRC_URI[md5sum] = "9be2e48db37920f21925ae6e88f83b84"
12SRC_URI[sha256sum] = "14cfc584cd3714fe8c9a2cdc8388be49e08b5e395d95e6bcd11d4410e2505ca2"
13
14EXTRA_OEMAKE = "ds9097 ds9097u \
15 SYSTYPE='Linux' \
16"
17# Fix GNU_HASH QA errors
18TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
19
20do_configure() {
21 rm -f digitemp_*
22}
23
24do_install() {
25 install -d ${D}${sbindir}
26 install digitemp_* ${D}${sbindir}
27}